Everything was fine.... until

I have been running my 180w 55" X 36" Chinese laser about 14 hours a day for that last few days getting ready for a craft fair next month. I was also contracted to engrave the logo of the event on the wine glasses that will be sold in the beer garden. I sent them the wine glasses for approval a couple of weeks back and got the ok to go ahead and engrave the glasses. I set up my PiBurn 3.0 in the laser like normal, flipped all the switches and toggles in LightBurn like I always do.

Today, when I sent the image to the laser to frame it on the glass, the rollers seem to be fighting against themselves, rattling and shaking and vibrating with a terrible noise. I went through as many trouble shooting steps I could think of, like restarting everything, reconnecting things, turning off power, the works.

I disconnected the PiBurn and sent in a trouble shooting ticket to them.

Now, the problem has jumped over to the actual laser. The “Y” is fighting its self on the laser, no matter what I do, I can not get the laser back to home. Now I’m really stuck

Any ideas?

Do you load any configuration data to the Ruida before you use the rotary?

Did you disable the rotary before using the table?

Does it home properly when you power it up?

Do you have a backup of the factory configuration data?


There is just a plug at the end of the wires coming from the motor. That plugs into a switch that is thrown after directing LightBurn to enable the rotary. LightBurn communicates with the rotary. I’ve input that it’s 10,000 steps, and that information is shown in the control panel.

I don’t believe I have ever done a back up on the Ruida… I wouldn’t know how that is done.

What control panel?

I have a PiBurn 3 also and my steps/rotation are 2000 when I apply the drive ratio in the device, 2.5 to the 2000 that gives me 5000 steps/rotation.

Is your step value different?

Again… does it home when powered up?


Control Panel… The window that opens when you choose “Rotary Set up” from the Laser Tools drop down menu in LightBurn.

As to the question of does it home when powered up? Are you asking about the laser or the PiBurn?

Right now, if I turn on the power to the laser, it’s locked up on the “Y” axis… fighting it’s self and rattling back and forth unless I put the switch for the rotary in the neutral position. The “X” axis is not having the same problem as the “Y” axis.

Unless you figured out how to add/connect home switches to the PiBurn I’m talking about the laser without the rotary… Switches set for normal table use.

If it doesn’t what does the machine console report?

If it starts making noise, you can press the esc button to escape out of the home operation and then you should have manual control over the Ruida from it’s panel.

If the machine is trying to home and you press esc, it will abort and not show any kind of error…

If the procedure you advised it what happened, the only thing that could be a problem is the switch/associated wiring that controls which Y axes output you are using.

This would be the only thing that changed… ?


I have the laser back online by doing these couple of things… No idea which one solved my issue, but this is what I did.

1.) I turned everything off and unplugged the machine from the power outlet.

2.) Walked away for a couple of hours.

3.) Restarted the machine with the rotary switch in the neutral position, waited a few seconds to hear if it was going to make those terrible noises. When it was obvious it was not moving or making noises, I hit the escape button because it wasn’t going to be able to get the gantry back to the home position.

4.) Manually shoved the gantry back to the home position.

5.) Restarted the laser.

The laser made a huge clunk, then found its zero settings. I was able to move the gantry along the X and Y axis using the directional buttons on the panel. I feel like I’m going in the right direction and possibly have a solution should this happen again. I’m going to re-attach the PiBurn and see what happens.

Plugging in the PiBurn and running the “Test Button” has recreated the problem again. The rollers are fighting each other and they are just rattling and vibrating.

But after disconnecting the PiBurn, the gantry responds as it should and didn’t develop the problem like this morning.

I’m trying to find something common with your issue(s) that might help us point to something.

I assume it worked before?

If you are doing exactly the same procedure every time and the results are not consistent, then I’d suspect a lose connection…

I also suggest you configure the machine as it should be with the toggle switch for the Y table when you boot it… Don’t use the neutral position…


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.