Exported Dashed lines from illustrator become solid lines when opened in Lightburn

Exported Dashed lines from illustrator become solid lines when opened in Lightburn,
How can I fix this, IN Illustrator?

Outline doesn’t work, it creates rectangles

Simply put, I don’t want to redraw all of my Dashed Lines in Lightburn. Also other drawings where portions of lines are masked in Illustrator, “re-appear magically” and I haven’t figured out how to shut them off. Or merge them down, etc…

Can anyone one help?

thank you!

I’m not sure of AI’s terminology but you want to expand the stroke before export.

Thanks Sonnyh,
When I “Flatten Transparency”, and then “Expand” my nicely Dashed Single Lines become Tiny Rectangles There must be a way to resolve this in illustrator without having to redraw the dashed lines in Lightburn and try to recreate them there.

Housekeeping side note: My exports have been PDFs so far, should I switch to a different file type for Lightburn import?

It has been a while, but if I remember correctly, in Illustrator go to the menu for Object → Path → Outline Stroke.

The point being, you need to convert the stroke defined into paths, then the export will produce shapes that form the dashed lines you’d like.

Thanks @Rick it’s been a long time since I used AI. @moleculeism the format you export should not matter, it’s what you do before you export that matters.

As a side, LightBurn also provides a ‘Perforation’ mode in the ‘Cut Settings Editor’ allowing you to produce “dashed-line” output, without needing to “draw” them as dashed. Just a suggestion of another possible workflow to accomplish the task. :wink:


Thanks Rick,
Yes, when I “Outline Path” the clean vector dashed lines turn into Multiple Rectangles in a Row, creating a line. So now I’m cutting hundreds of rectangles instead of just Dashed Lines… This is one of the issues I’me trying to avoid because it seems like over kill and takes twice as much time. I’m using the design to cut card stock, I just want the laser to cut a number of straight dashed lines, not hundreds of dashed rectangles.

Any idea of how to Create a dashed path in illustrator?

Stroke and line width are the issue when generating this art. LightBurn is for laser cutting design and does not support the concept of a “width” to the line. The width of a line is the size of the beam. Stroke is like a mask applied to the line and must be converted to paths first.

Did you get a chance to look at the ‘Perforation’ mode in the ‘Cut Settings Editor’ stuff I provided above? You could change the format of your dashed lines from within AI to remove the Stroke and set the width to 0.01 or so (beam width small :wink: ) and set them all to a unique color to make it easier to import them all on the same layer in LightBurn. Export that version of your file for use in LightBurn.

Import that file and set the layer containing those ‘desired to be dashed’ lines to ‘Perforation’ mode, adjusting the “cut and skip” as needed to produce the dashes automatically when the job is run. When using this, and most everything in LightBurn, ‘Preview’ is you friend.

I have the same problem going from Corel to RDWorks. Any ‘line’ exported becomes a solid line. If I take a few short lines, like 2mm or so long, and duplicate them along an axis, then it exports and cuts just fine. I have no idea what the difference is between a dashed line and a series of short lines, but it works.

We could feasibly make LightBurn support the dashed line from the AI file, but it would become lots of short segments once in LightBurn, not a single line with breaks. Perforation mode works like that, but it’s an “output only” option on the layer, and doesn’t draw that way in the edit view, and it’s a layer setting, which we don’t alter when importing vector art.

1 Like

Bingo Rick,
This works well, Preview is Key, that’s Point #1, or it seems like the plan isn’t working.

1 Like

Also true for ‘Dot’ mode, ‘Kerf’ settings, ‘Invert Image’ and I may have left one out. :wink: @LightBurn? These settings are also not shown in the workspace but are visible when in ‘Preview’.

Oz Edit: Tabs work this way as well, and image modes like threshold and dither.

Ralph, when you say “I select the dashed lines in AI, and change their width to 0.000001.”
Are you speaking about “Stroke Width” Cos I can’t get the stroke width to that small of a percentage.
Please confirm what you mean by “Width”

Hmm…I couldn’t get this to work. Your examples worked fine, but my export did not. I used the oldest…“illustrator 3” I believe (that’s super old). @RalphU can you share all exact export settings?

thanks in advance!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.