Exporting options problems

I am having problems with exporting files finished in LB, I have imported art, then edited it in LB. However, when it is finished I would like to Export as DXF or SVG files. I have yet been able to get this to work. Am I missing an option or something??

Win10 pro x64
LB 0.9.06

I loaded a recent project into LB and selected File, Export. Under the menu drop down for file types, I have SVG and DXF and AI.

Does your program not display those options?

What are the steps you are taking to attempt the export? As @fred_dot_u identifies, choosing ‘File’→’Export’ should bring up the save dialog and allow the choice of 3 file types in the drop-down from that window, .AI, .DXF, or .SVG. Is this not working for you?

image

image

I do have the option but when I name the file it does not save anything, doesn’t even leave an empty file.

I am not getting the same. Using 9.06 mac version, I export to DXF, then open that file via online browser-based viewer. Same results for SVG files. What else can you share that might help us help you with this further?

Is the imported file a bitmap? When you edit it, do you create vectors/paths which is what is expected to be exported. If you are only modifying the bitmap, it seems likely that you will not be able to export it as a vector type (AI, DXF, SVG) which may be the key to the problem.

So I am importing the svg file, making a few edits, and adding a couple shapes. then I try to export to a svg file, give it a name, a location, then nothing is made. With this said I have never been able to get this function to work, I am guessing I am missing something that I need to do.

Are the items selected when you try and export?

I have tried with items selected, and without selecting various items. I am at a loss with this feature.

So, to add a little more info I found also that when t I run the preview app, there is an option for save as picture in there. I tried it and I get the same result no file saved.
Has anyone seen anything ever posted about maybe another program blocking lightburn making files?

I’m also not able to export any format nor save the preview image.

Using 0.9.07 on Ubuntu 16.04.
So it’s not because of Linux :wink:

Because I recently mount a mill on my CNC I would like to export the finished design to easel by using dxf or svg format.

But LB does not create any file excep .lbrn

I am just as relieved as you that it’s just not me… lol
I’m still working on a fix or some insight.

Do you run anti-virus software? It’s possible that it’s blocking the ability of LightBurn to save, though that would be the first I’ve heard of this. LightBurn also saves your preferences, so it would cause many other problems if it couldn’t write files.

I run Win10 myself for development, and can export to all the supported file types. I just saved the preview to my desktop, calling the file “PreviewTest.png” and this is the result:
PreviewTest

I haven’t heard from any other users having this issue. Is anyone else experiencing this?

Ok, so I think your onto something. I just grabbed my laptop and to see if I could replicate it on there. It doesn’t use AVG. It did save a dxf file.

You might have to tell it that LightBurn is safe. Older versions of LightBurn were not digitally signed, but the new ones on the PC are. It’s possible that it “locked down” the app in the past and hasn’t ever loosened up the restrictions.

The safe list and exceptions list didn’t work, so going to go to extreme action and uninstalling AVG and see if that makes a difference.

Ok, that was a lot of chasing my own tail. Found my “Ghost in the Machine” so I’m glad I use a clone drive to make changes before doing it to my main CPU.
Long story short, AVG not my gremlin. I deleted the preference files in the appData/local/lightburn and then restarted lightburn and it fixed my problem.

1 Like