EZCAD2 - MAX Fiber Laser? how to set it up properly in Lightburn?

I actually got Lightburn to work, but what kind of puzzles me is this:

According to my laser’s manufacturer (got it off Aliexpress…) it has a MAX Lasersource (20W, 20-60kHz…)
Now in lightburn, I can set the laser fiber type as RAYCUS,JPT, IPG_YLP, IPG_YLPM but not to “MAX”

Firstly I don’t really understand what this setting does influence … and which one I should choose in my case, as the MAX isn’t listed?


This identifies the laser source type - they are the various manufacturers. There are all of these types present and Lightburn needs to know which type the controller is driving.

Did you import the markcfg7 file when you installed the device? If you didn’t it won’t know what source or have your lens correction applied.

You have a Raycus source … according to your profile…?


EZCAD has essentially been a pretty bad issue to boot with.
My Laser has a EZCAD2 controller - thus lightburn works…
but the manufacturers USB Stick does not seem to contain the proper markcfg7 file…
there are several versions of EZCAD2 on the stick, and in total 14 different markcfg files!
I’ve tried to load ALL of them into lightburn, sadly not a single one of them matches the specs of my laser…
and yes I’ve contacted the manufacturer and we seem to have communication issues - they insist I need to install the driver (which I did…) and set up EZCAD with their Spec sheet… I can’t because EZCAD throws a “dongle not found” error regardless which driver I install.
And they don’t seem to understanfd my request for the correct markcfg7 file.

I’ve then manually set up the parameters and got lightroom to burn things, quite nicely to be honest.
but again, that setting “fiber type” I can’t go and adjust.

my laser has a MAX laser source according to the manufacturer… not a Raycus.

Sorry, must have gotten you mixed up with someone …

I’d ask them about the missing dongle issue and you can’t follow their instructions without EZCad working…


doesn’t need a dongle - if it recognises the driver… apparently… and again it’s working in Lightburn - I don’t need EZCAD to run… I only need the config…

1 Like

Ultimately, the “Fiber Type” setting is just the communications protocol that LightBurn uses to talk to the controller and source in your machine. If it’s actually firing the source and working properly, then you should be fine as far as that setting goes. What you will be missing without the proper markcfg7 file will be your lens configuration though, as far as scale, bulge, etc. But, with the new 9 point calibration build into LightBurn, you can properly calibrate your lens.

Thanks a lot…

OK - I’ve been quite succesfully marking a few steel pieces now…
had to correct for scale, red-mark offset, and will do the 9 point as soon as I get my black card stock deliverd for cheap marking test.

As things seem to work rather well I think I just toss EZCAD out of the window(s) :wink:

thanks for the help

I tossed not only EZCad out, but windows along with it :crazy_face:

Glad you got it at least doing something you want… was it anything special?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.