EzCAD2 Windows 11 Setup

Maybe you can help me with a major headache…

I have my wifes Windows 11 machine and I’ve tried to follow multiple instructions on how to install drivers for EZCad2… I’d like to try the lens utility…

The fiber shows up in the device manager, but it’s under the USB and has the yield sign with a exclamation point in it.

I can uninstall it, but if I unplug and plug it back in it reappears. I’ve tried to update the drivers, but it complains that the right drivers are there already.

I have gotten to the right directory and it finds the .inf file, but says it’s the wrong software for my machine. I’m trying to load the 64 bit version and Alex at Laser Everything say it’s for Windows 11.

I disabled (I think) the driver signature requirement, but the results are the same.

I’m kind of clueless about where to go with it. No matter what installation path I follow it ends with the same two option of it’s already the best driver or it’s the wrong software to install.

Any suggestions?


Right click on the one showing the yield sign and click properties.
One of the window choices “should” show you what the problem is.
Send a screen shot of the bad one.
Hard for me to say since I don’t have any with the sign right now.

You’ve got your own thread here now for your Galvo setup.
I hope you and @Bikemike continue the exchange here.

1 Like

This is where my frustration with windows always gets me…

I had the described issue, last night and put her pc on the charger.

Today I sat down to it and the usb entry I mentioned was missing, but the laser entry was there and working… it wasn’t rebooted, just put on the charger…

I had previous rebooted it, but had the same symptoms…

I wish I could tell you what I did, as I’m sure it will come up again when I mess with the drivers… I’m going to leave it configured for EZCad2 and try to calibrate a couple of my new lenses…

Just got an F254 (174x174mm) specifically for 6" square tile… all the time I’ve spent with windows, I could have had it calibrated by now :face_with_spiral_eyes:

I want to thank you for the help. Guess I wasted this thread… no fix that I can advise.


Is the laser hooked up to it? If not, it will not show you the sign. Only when it finds something that it thinks will not work.

I used the laser from EZCad2, so it’s talking … at least I framed something…


In that case, Let’s see where it goes. It usually will not fix it by itself, but who know with windows.

That seems to be my biggest hurdle… it seems to do things that don’t make any logical sense… obviously not designed by a Vulcan… :face_with_spiral_eyes:


Let me know if it keeps going or decides it made a mistake and flags it again.

I’ll keep you updated, but I think it’s going to fly… I’ll know for sure after I watch the calibration video again using the cor file generator…

I did two without the cor file generator, I’ll see how much easier this is, now that it appears I can try it…