Failure of lightburn to recognise my laser after updating software

Hi all
I’ve just updated Lightburn to latest version and now it won’t recognise my Laser which is an Atomstack A20 Pro 130 watt machine with the extended laser bed fitted ( 850 x 400 ).
I’ve tried installing the driver for windows ( CH34X for Windows ) but it still won’t recogniser my laser.
I’ve followed the advice to install it manually but every time I select “Frame” the head travels too far and keeps banging on one of the side extremes.
Can anyone please help as I now can’t use my machine.
Best Wishes to you all . . . . Eddie.

Try file> open pref folder and load a pre update config.

Hello and thanks for your reply. Tried going back to 14.01 version ( originally used ) and same problem occurs.
Tried following advice given in Lightburn YouTube recommended by their support team - no different - head just travels to random places and bangs against side rails.

I was wrong and meant to say File> open pref backup and pick a pre update back up.
Did you try back up or just reinstall an older version?