Falcon 2 only works with TF card, Lightburn stops working in the middle of progress

Hey guys, I’m kind of lost here. I spent 5 hours straight trying to fix my problem with the Falcon 2. I just received it today, but when I try to engrave or cut, it stops suddenly with no warning or signals. I’ve tried everything - switching to a different wall socket, using a different computer - but nothing seems to help. Strangely, when I saved the G-code to an SD card and ran it from there, it worked perfectly fine.

What could be causing this issue? Also, can someone explain why the beep sounds are so loud? A neighbor actually called the house caretaker because she thought there was a fire alarm going off, when in reality it was just the loud beeping from the Falcon 2.

I would really appreciate any help or suggestions you may have. I’m eager to start creating some fantastic projects!

Couple questions
Are you importing your profile into lightburn of buildin your own?

Have any appliance nearby starting/Stopping?

Does the same happen if you run the same project but at 1% power?

Sorry for answerin that late, i solved it, the problem was the software version, it was an very old lighburn version, after i updated, everything went good! I really dont know why i had downloaded this old version, i think i got it because i was searching for a 64bit version and somehow landed on this very old version and was not even sure if it was 64. After updating the 32bit version, there was a message , i should download the 64bit version. After doing that, everything good!

1 Like