Faulty Lightburn Camera

Unfortunately the lightburn camera I have received is faulty.

I have tried several machines and with the drivers that were sent to my email. Windows machines (2 win7 machines and a win10 machine) say device malfunction, if anything at all happens, device manager has something pop up for a second and then vanishes, lsusb brings up nothing on my linux machine.

I have contacted lightburn support via email (always politely) and I have not heard back in 3 days.

I feel ashamed to post here because I was so pleased until this experience and would have preferred to resolve the situation via email / privately.

They haven’t given any information on what else I should try or where to send the faulty camera…

Anyone else have problems like this?

I am trying to understand how this might have slipped through our system. When I look at the response provided, it looks like we did respond and also ask you a question, but you did not reply.


If you would like, we can go back to the support email system to resolve this. Your call as we want to help you get sorted.

Hi, I did reply on September the 25th and again on the 26th, I can see it in the email chain on my side. Lets continue there…

Hi Rick, I just tried to respond to your email and it bounced…

Other emails I send work fine from my address…

It looks like there are some other technical issues going on here. I’d really like to sort this out.

Perhaps we could use the forum PM service?

I see we have re-connected via support email system. We will sort this there. :slight_smile:

well im having a problem getting it to recognize my camera the computer sees it and says its working fine but when i hit the windows tab it sees it but wont let me select it

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.