Fiber Laser Rotary Tool is too slow

Hi there,
I have a fiber laser with a rotary that I have used with Ezcad 2. Everything has been working very well with Ezcad 2. When I try to change the speed of the layer in Lightburn (mm/s), It keeps using the minimum speed (pulse/s) of the rotary tool. I would like to know what could be the issue? In Ezcad 2 whenever I change the layer speed works very well.

How about screen shots of your rotary setup and layer parameters where the speed shows up?

I have tried with different speeds, frequencies, powers etc. I have also tried these parameters in Ezcad 2 and it worked just fine. Here in Lightburn, 2000mm/s with the rotary tool is painfully slow.


Other observations (I’m not sure if they are related to the issue):

  1. Above the “Pause” button keep switching between “Framing” - “Busy” while engraving
  2. When I press the “Test” in Rotary setup, it rotates quickly and smoothly, but when I engrave something it seems like the rotation is not that smooth (meaning it steps-stops-fires and it’s noticeable, just like when you decrease the speed under 100mm/s in Ezcad2)

Either I’m misunderstanding you or you’re misunderstanding how the number work here…

The 2,000mm/s is 2 M/s which is extraordinary fast for mechanical things…

You split size is very small and is likely part of the issue.

The 2000mm/s is how fast the galvo is scanning not the speed of the rotary… unless you are trying to spin the object at 2 meters/s… if so, you will eat one when it comes off the rotary. :wink:

Mine does this all the time… I think it something to do with how Lightburn is communicating over the usb with the controller accepting it… but just a guess…

This is a good indicator that it’s working properly… so I think we should look elsewhere… :wink:


1 Like

your split size is very small, basically telling the rotary to make move 0.020, scan 1 line 0.020, and then move 0.020. Lightburn is calculating 3289+ slices, which it can do easily enough but resource consuming. This may not be the issue, but I would suggest changing split to 0.200 or something like that. Also, 16000 steps seems unusual, none of my drivers do that amount of steps. Do you have a gear reduction rotary?

1 Like

I have a standard D80 rotary, it’s motor driver is set to 12,800 steps/rotation… that’s what I run…


This is the description of my rotary, the seller told me to use 16000 steps/rotation and weirdly enough it started working properly

I know that the split size is really small, but that is what I have been using in Ezcad2 to get nice engraves without big gaps between line. And about the 16000 steps, the seller provided this number and it started working well in EzCad2…

I understand these number, but after hundreds of trials and errors, my Ezcad started working well with these numbers. Probably my Ezcad2 works on a different plane and I try to use the same setting in a well made software…

I used ezcad before LB, but my rotary was 6400 before, 6400 after. You say when you run test, it rotates smoothly forward and back. Are you putting a mark on it and actually verifying it turns exactly 360 degrees?
If it was me, not knowing the history, looking at the line " Transmission mode…2.5…" and you say your driver is set at 12800 I would put 32000 in the box. If your driver is actually set at 6400, then it would be 16000 like you indicated.

As for 0.020 split, as long as the rotary is capable of turning that small of an increment, LB can handle 3K or 4K splits but from experience the rotary may slow down and even stop for a second or 2 if you have any other background operations going on.

1.) that is normal, each slice Framing-Busy
2.) That fine step is gobbeling up resources. Try with a fresh boot, only open LB.
As Jack noted, speed is the laser not the rotary. Looks like your rotary is set for 5000 , I run my 6400 step rotary at 3000 and my 38400 step at 6000 so you are probably about right. You could probably shorten up the acceleration time from 100 to 25 or 50. What’s happening is the rotary is taking 100ms to come up to full speed, but moving such a small amount it never reaches it.

Sorry I’m all over the place with these posts but I’ve been getting interrupted.

Suspicious about the word decrease used in that statement… Could it be that it’s computed with 1/2.5 for a reduction so it should be set to 5120…? :wink:

If the test button works properly, I’d look elsewhere… I know test works and it only works if it’s configured right.

@laszloharai I had to set all the delay timings to 0 to get the best speed… just a screenshot of it in case you change it so if it doesn’t work you can set them back… I also removed bidirectional scan, as it probably won’t line up… still runs faster.


It makes exactly 360 degrees with 16000 step per rotation.

1 Like

I know that the speed is for the laser, but in Ezcad the laser speed increases the rotation speed as well, which is missing here. The laser works fast but the rotary rotates slow in LB. That is my main issue. I have tried to increase the split size as well, and it takes larger steps but still rotates slow.

Chinese translation!
I read it as 2.5 rev input = 1 rev output so if driver is set for 6400 it would take 16000 pulses to rotate 360.
Makes sense with everything above.
I don’t think Bi would matter, makes one pass left to right, moves 0.020, makes one pass right to left…

If you follow Laser Everything photo video where you align the scans, these are the values I changed to zero… the delay timings…

It definitely does break tho correct operation in a bidirectional scan operation… Without these delays, the scan lines don’t line up…



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.