File Invalid Unkonwn File Error On Ruida Udisk USB Drive

I have a 60W red and black Ruida controller laser and I can’t seem to use RD files from a USB stick.

I insert the USB drive, then go to File, then Udisk. In the Udisk menu I can see all the files, but when I click Copy to mem, I get the following error:

“File Invalid unknown file”

I have tried a couple of different USB drives and different files but I always get the same error. The USB drives are FAT32 file system, the file names have no spaces and are .rw extension.

Also, I can send RW files directly to the laser via ethernet cable just fine, which is what I usually do but it would be nice to also be able to use the USB stick for files I use regularly.


Dunno if it makes a difference but the files that I transfer to a Ruida controller on a Thunder Laser Nova 24 all have an “RD” file extension.

1 Like

Yeah that was a typo in my post and it seems that I can’t edit it now. Mine are all .rd also

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.