File Size Trouble

Desperate need of anyone to help me. I have a photo I’m engraving at 2 ft X 3 ft
My jpeg file is too large to send to the riuda controller (even though my computer tells me it’s only 9 mb, lightburn and my controller say it’s 140 mb) anytime I’ve engraved an image without first sending it to my laser, my job would always get about half way done and just go off on its own path and shutdown. So since then I’ve sent photo jobs to the laser with no issues.
Anyway I’ve tried exporting the images as different formats, to reduce file size, nothing. I need the job at the exact size and at 400 dpi in Jarvis.

Any recommendations on getting this thing to run? Or reducing the file size?

How are you connected?

I had too many issues with a direct connection to the Ruida via Ethernet and over the wired lan. Some of my larger files repetitively failed to load.

I went back to the Lightburn Pi Bridge and haven’t had any issues loading since…

If the file fails to load, do you see the entry in the lcd of the control panel?

I was curious about

Something is fishy here… just from the file size mismatch.


I’m connected with a USB cable from my laptop to Laser. I’m not even sure what the ligjtburn bridge is to be honest or how to use it.
I’ve also never had any troubles starting any files from the laptop, and the larger images I would send to the laser controller, wait for them to load in the LCD screen and then start them from there. Unfortunately this file has been giving me trouble all morning and I’m scared to just press start on ligjtburn on the laptop because I believe it’ll go haywire later into the engraving.

Lol and yeah file size is baffling me as well

The Lightburn Pi Bridge is a wireless bridge with a layer of Lightburn software that deals with some of the issues in the UDP communications with the Ruida.

The usb is not very dependable. I’d recommend moving to an Ethernet connection. It might be the most simple and lowest cost. Much better than the usb connection.

Good luck


I’ll check it out. Thanks for the help. I noticed it’s sold out on the lighburn store. Is there another place there’s are available?

How many files on the controller currently? Do you have a USB flash drive connection on the side of the machine? Maybe try that.

1 Like

@micrololin is thinking correctly, might help to delete any extra files you have on the Ruida… and try the USB sneaker net…

I’ve found the usb connection the worst there is…

The Pi is about sold out everywhere you look… I just purchased another Pi 4B, 2gB memory about $100, normally they sell for about $60 but they are in demand and aren’t available from many places. Seen them with 4gB of memory for over $220.

I had a Pi around so just loaded the firmware on it and ran it.

The machines in the garage with no wired Ethernet. I plug my Ethernet port on the PC to the Ruida Ethernet directly when I’m using the Pi for other things.

The other licensed copy of Lightburn is on that computer.

Can you go Ethernet, at least to see if it helps…?


I’ve deleted all files on the controller, I do also have a USB port that I loaded the file onto to run on the laser but I found out it had to be copied off the usb into the controller and there wasn’t enough space. Seems to be an issue with this file because no matter how I save it and at what resolution I save it at, it doesn’t want to drop in size for whatever reason. Unfortunately the Ethernet cord is not an option as my laptop and machine is in the garage and no where near my internet access. My files seem to always start fine but I was told before on this forum when I had issues with large photo engravings (usually anything over 2 feet) that the controller couldn’t keep up with the incoming information being sent from the laptop which caused the laser to veer off and stop about half way through my engravings. My friend has Full spectrum laser that uses its own program. I may try it on his just to get this job over and done with

One of us is confused about the Ruida… Most grbl machines are feed by a serial feed. I understand that the Ruida needs to have the whole file loaded.

How else could it frame if it didn’t have all the data.? It also computes the overscan so all the data would have to be there.

I might be off base, it wouldn’t be the first time. If you don’t have the free memory in the Ruida, maybe it’s not possible.? Someone else needs to hop in and speak, if they know…

When the Pi becomes available, I’d go with that. The low cost option is a wireless bridge from someplace like amazon, give you a wireless link to the bridge then via Ethernet.

I used this one before I had the Lightburn bridge and it worked well.

Good luck


Thanks for the information, I’ll have to check it out. Does the product you sent plug into the laser via Ethernet and then I wirelessly connect my laptop to that? Sorry I’m just not familiar with the whole process .

Yes, the ‘wireless’ bridge does just that. You have your computer → lan → (wireless) bridge → Ethernet connection to the laser.

It has a short configuration to make it a bridge in the supplied ‘manual’. Whole manual is a few pages long…

The IP on the laser needs to match the lan ip scheme… It’s easy to change the IP/Gateway on the Ruida.


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.