File Transfer Failed - multiple instances?


I transfer files to my laser many times a day normally without issues. Every once in a while I receive a message that the file transfer has failed and the machine may be busy. This issue seems unavoidable without a reboot of my computer (tried rebooting laser, restarting Lightburn, and unplugging the laser USB with no luck). After a reboot things are back to good.

Just recently, I had the issue again, but I was offered a newer version of lightburn. Assuming this may sole my problem, I downloaded the installer. On the setup wizard, it informed me that I needed to close some programs before it can continue. LightBurn was listed twice (only one instance was open on the desktop) I closed my instance and tried to continue the wizard. It still claimed I had LightBurn open. I closed that “phantom instance” thru my task manager and the install went successfully and I could transfer once again!

I have now still been running into this issue where the file transfer fails. Now, instead of a reboot, I can close LightBurn, go into task manager, and end that “phantom instance”. Reopen LightBurn and all things are good again.

It appears, at some point and time, LightBurn opens another instance or process that blocks me from communicating with the laser. Do you have any other suggestions or troubleshooting I can try?

I am using Win10, Ruida controller and a wired USB connection

It shouldn’t be LightBurn opening that phantom instance, at least, not exactly. Do you often double-click files to open them in LightBurn when it’s already running? There’s code to check if one is already running, and if so, to tell that one to open the file instead, then the new one closes. It’s possible that it’s not closing for some reason, though in that case I’d expect there to be more than just one hanging around.

I’ll have a look at the code for that and see if there’s anything in there that might fail / hang if there was a weird case.

Thank you for the response.

My general process is to leave one instance of LightBurn always open. Then many times i use the Open or Import buttons to bring in my files.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.