Filed failed to send via ethernet cable

Been having issues with filed failed to send, worked with Thunder laser on issue. I was asked to post in lighburn. So I am connected via ethernet cable to my Nova 51 w/RDC6442G-LY-B ruida controller. Been having this issue since the machine arrived early this year. I’m now starting to use it more so I really need to solve this issue it’s become a time crunch. So I have changed cables many times, cycled power to machine restarted lightburn, restarted my pc. After logging this many times, I have actually noticed that if you let it sit for maybe 10 minutes or so that you can sucessfully send the file after clearing the fault without restarting anything. I have tried unplugging cables and using different cables, same cables and now this. Doesn’t make any sense to be able to let it sit for a period of time and then be able to send the file with no issue. ANY IDEAS???


Not enough information to go on. Not psychic.

Nice to see TL offloading support. YGWYPF, or not, in this case.

Maybe some inkling as to your computer, OS, its network settings, how you are connected - the topology of your network, etc.

It invariably points to your network being the problem: poorly configured network parameters, bad physical layer, unreliable router, emf interference, crowded wireless, poor-quality components in your network.

Without details of what you’ve got and how it’s configured, could only guess.

RuiDa is network-stupid. Really basic observance of tcp/ip framing. Nothing but the most rudimentary protocol support. As a result, reliable as hell. Get the address right and it’s bulletproof

Windows, an utter nightmare of a network device. ISP-supplied network hardware - the cheapest crap they can get away with supplying and not lose customers. Usually only good for a couple of concurrent connections

ok so maybe I didn’t enough information but if you really were paying attention, you would have read that I am connected via ethernet cable. But you were to busy formulating an ignorant response to notice. Also Thunder has been nothing but helpful, like I said if I left the computer alone for a period of time after clearing the fault I was able to then send the file with no issue but this is not time sufficient. So it wasn’t the machine, yes it may be my computer but I was asked to post here since I am using light burn. I am not an IT guy as many people who own laser are not. But I was simply asking for some assistance.

For the helpful bunch, I am using a PC, and I am not an IT person so I don’t know my network settings. But I am connected via ethernet cable from my pc to the laser directly.

1 Like

If you are connected directly from the PC to the machine, it should be pretty bullet proof. Bo is correct that the Ruida controller is using a very minimal network implementation, and they use UDP, not TCP, with no retry mechanism, so if a packet is dropped, that’s it - the transfer is abandoned and you have to re-send.

Make sure that the network cable is well seated in the sockets at either end, and not running next to anything like a compressor motor or A/C fan.

In Edit > Device Settings, you can try increasing the network timeout, which can help if it’s the controller pausing to reclaim space. If you are sending large files, this can happen, and it’s more common if you leave a lot of files on the controller and don’t clear it occasionally. In cases where the controller is close to full, they can be somewhat unstable.

Thanks Oz, there are a number of factors here you mentioned that come into play for me. My HVAC system is within a few feet of my computer, I know this has happened with the controller memory being full, but I believe it’s also happened empty. I will try to keep track of that as well, As for the cable being seated all the way, don’t know what to say I have used many cables and got the same results, so unless my port on the pc is shot, I can’t really say it is or isn’t that. Also it’s been large and small files, however I will try the device settings you suggested as well as relocating my laptop away from the HVAC unit.
Thank you

If you’ve tried multiple cables, it’s not likely they’re the cause. There is a short extension in the machine that connects the controller inside to the plug in the case, and once in a blue moon those are bad. You could try opening the side panel to expose the main controller box inside (the white smooth plastic box with lots of wires going in). On one end you’ll see PC-USB, UDisk, and Ethernet ports labeled - try plugging directly into the Ethernet port there, and if that works that could be the problem.

Thank you Oz, it was the ethernet extension adapter that you suggested. I ran a whole week without one file failed to send, by plugging directly in the port inside the machine. Got a new adapter today in the mail from Thunder.


Happy to help - it’s nice when it’s actually something concrete like that, instead of random gremlins. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.