Fill all shapes at once, not filling all shapes at once


I hope I am able to explain this issue correctly.

When running an engraving test (the file that’s squares with the powers and speeds), the laser cuts straight along the X axis for all the squares, despite power and speed settings. By doing this, it is engraving everything in a line before moving to the next line - it is not engraving one square, then the next square, etc.

I am trying to do this with some designs/photos that are close together and engraved at different speeds/powers. How do I tell the laser to cut everything along the axis (x or y) and NOT each layer individually?

I have selected “fill all shapes”. I have grouped things together. Nothing is working. I have selected each fill option and they all do the same thing.

Hopefully someone has the answer!

@ColleenMarshall I’m sorry that I cannot help you, Colleen, but can you post the test file that you are referring to? I have a test file, but it fills square by square. Each square is on a separate layer.

What version of LightBurn and on which OS? Just did a quick test here and things are working as expected. Please post screenshots of your example, so we can “see” what you are observing, and we can go from there. :slight_smile:

Edit: I see MacBook Pro listed in your profile. Machines, in this case include the laser and motion control system driving this laser. This helps when you post, so we can look for your specific configuration.

If you have multiple shapes on different layers with different speed / power settings, what you’re asking for isn’t possible. If the shapes were all on the same setting layer, it would be possible.

I am bad at explaining things haha so here is a time lapse (you can scrub to see better) to explain what I am trying to achieve.

Each row is a set of squares under the same speed. Each square is the same layer, yet filling at a different intensity. How did they do this?

When I had originally wrote the post, I didn’t realize each row was the same speed. But none the less, how do you tell the laser to engrave the boxes at different intensities if they are on the same layer?

That’s done using the ‘Power Scale’ value on Shape Properties.

  • Create a series of shapes on a single layer
  • Set the Min Power below the Max Power
  • On each shape, adjust the ‘Power Scale’ value
    • 0% power scale means you get ‘Min Power’ outupt
    • 100% power scale means you get ‘Max Power’ output
    • 50% power scale means you get halfway between min and max power


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.