Fill all shapes at once vs. Fill shapes individually bug in 1.4.0?

I just upgraded to 1.4.0 on my MacBook Pro (3.3 GHz Dual-Core Intel Core i7). The first job I sent since the upgrade, I had a fill layer specified to be “Fill all shapes at once.” My laser (Boss Laser HP 3655, Trocen AWC 708C controller) engraved things as though I had chosen “Fill shapes individually.” I went back and checked my Preview window, and it indicated the same behavior. Once I grouped the shapes, they engraved the groups together. Preview indicated this change as well. Could this be a bug that slipped in for version 1.4.0? Thanks.

This doesn’t help with what you are experiencing, but just to put it out there ‘fill shapes individually’ is working as expected for me running 1.4.00 and Windows 11.

Not clear at this juncture. Need additional information first. :slight_smile:

Please share a few screencaps showing the Layer settings along with how you have Cut Optimization Settings configured, and the Preview with Traversal Moves turned On (green) so we can review.

Here are the requested screenshots.

Oops. Here’s the other requested screenshot

Please post this file, as it looks like you may have some duplicate shapes.

Here I show how I set for producing as you’d like with a Trocen AWC Profile.

I note ‘Order by Priority’ selected in your optimizations. Did you set a priority for the shapes?

The following may be of assistance in understanding how these different settings interact.

fillallshapestogethersample.lbrn (241.4 KB)

For the ‘Fill all shapes at once’, I see that you have each component that makes up the text is grouped as individual shapes, and you have ‘Order by Group’ also selected. The cut planner is doing just that. In this case, the cut planning grabs the first group from the first layer and fills the first group (example: fills the “0”, then fills the next group, “1”, then moves to fill the next group, the “P” from the word police, and so on. This is why you are not getting all the text to fill at once.

To resolve, you can ‘Edit’→’Select All’ to select everything in this project. Then ‘Ungroup’ the selected, then ‘Preview’ to ensure the job produces as you’d like.

The second way, leave the file as is and remove the ‘Order by Group’ from the optimization and you should see that works as you’d like as well.

Thank you. That does explain the behavior, but it still seems very counterintuitive that “Fill all shapes at once” won’t necessarily fill all shapes at once. The behavior in this case seems indistinguishable from “Fill groups together.” If I’d wanted that behavior, I would have chosen that setting.

What happens to my fill layers in general cases if I turn off “Order by group?” Or if I turn off “Order by priority” for that matter? Thanks.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.