Fill and line shifted at random


With the last update (v0.9.10) something strange happened. It is not necessarily a Lightburn bug but I have not found that problem anywhere.

A pattern is repeated 24 times with fill&line. Now the line is shifted to the left or right. Always the same direction with every batch but the count and position of the shifted patterns are random.

Any idea what could cause that?

bye Marc


Your machine is missing steps somewhere, so the fill pass doesn’t line up. Likely your acceleration or speed is too high on the Line parts causing your steppers to slip. What speed did you run the line part of the job, and show a screen shot of the settings you see in Edit > Machine Settings.

I can make a screen shot tomorrow.

Thought about slipping too. Speed is 500 for almost anything. For testing I have tried 400 and still the same shift.

Next I have changed one line of patterns to “fill groups together”. Finishing every pattern after another. Left another line to fill all at once. No shifting anymore.
Made a complete set of 24 with the “fill groups together” setting but the shifting appeared again.

It is sometimes in the middle and sometimes somewhere else.

The shift to the left was last week. I have checked and adjusted the mirrors again. Since that the shift is to the right. I can not think of any connection of adjusting and shift.

Perhaps a problem with the step counter?

If you mean mm/minute that’s totally fine. If you mean mm/sec, that’s way too fast for vector lines. If you mean parsecs per fortnight or miles per microsecond, those are too fast as well. (A number without units isn’t a speed, it’s just a number)

Not sure what you mean by “a problem with the step counter” - can you elaborate?

Random position errors are almost always caused by the steppers slipping because of you’ve exceeded some mechanical limit of the system. The slip won’t always happen in the same place, but it can.

It can be dependent on the order of the paths being run, and sometimes a simple order change is enough to make it go away. Have a look at this post (and the video) to see how very small motions at just the right speed and timing can cause major issues:

True. I had to check the units to be sure. I found some older photos of the axis settings and it is mm/s. I could attach those.

500 mm/s was the setting for months of production without a problem. But I do not think that this speed is really used. Start speed for the x axis is 20 and it can not accelerate that much for small patterns like letters. Or my assumption of how that is working is wrong.

I mean the stepper motor. Perhaps the belt is slipping sometimes.

Hey Oz, what would you consider a good speed to keep everything aligned properly? I usually run around 350mm/s , followed by lines of 15mm/s for cutting or 80 - 120mm/s for outlining, depending on the physical size of the pieces I’m outlining. Would you consider 350mm/s too fast for the vector lines?

It really depends on the hardware you have. Aeon and Thunder laser, for example, can handle cutting speeds of 400 mm/sec with no issue because they have their accelerations set appropriately for their machines. I’ve seen others slip when using the same settings because they set the accelerations too high for the motors used.

So, asking “what’s a good speed” is a lot like asking that same question about cars. The answer I give you will vary dramatically depending on whether you drive a Formula 1 racer on a closed track or a mini-van full of kids in rush hour traffic.

I have tested it with a lower speed of 80 mm/s. The shifting is still there. Always to the same side and at random places.

With a mechanical problem it would probably random in both directions and random amounts.

After installing version 0.9.11 I have tested it again with the speed of 500 mm/s. No shifting!

A coincident or there was bug in the .10 version.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.