Fill is skipping sections (Eleksmaker)

eleksmaker
grbl

(Brandon Brooks) #1

Hey everyone. I hate to ask questions on here when I still feel like I have tests to run, but at this point, I don’t know if any more tests would help.

I have been trying to get lightburn to work with my Eleksmaker A3 (not Pro, the original). Anyways, I’ve been able to make most of the configuration settings work fairly well (firmware: GRBL 1.1e), but I’m having an issue with fill settings.

I have a large library of images that I have “pre-dithered” so I use the threshold setting in lightburn for these black and white images. When I click on preview, everything looks like it will burn correctly, but the burn is often “skipping” sections in the middle where it shouldn’t. The most bizarre part of this is that it isn’t consistent. Without changing any settings, my first test burn last night worked great, but the same image with the same settings two minutes later wasn’t working. Getting it to run line settings seems to be just fine without any issues. I also tried creating outlines of the image to run the fill settings off of a vector instead of the dithered image, but the results were also inconsistent with skipped sections most of the time.

Here is the test image I’m using: Chili

I will try to post an image of what it is doing later (I’m limited to one image).


Skipping lines - mirror engrave
(Brandon Brooks) #2

This is essentially what I’m getting from the burn. Missing sections, not always in the same spots. Chili_wrong


(Brandon Brooks) #4

So after doing some more tests, I’m pretty sure it is a problem with some aspect of the firmware or hardware. I’m able to get the image to burn just fine with my k40 and the preview looks just fine. I’m going to keep this post here in case I find a solution. Then it would be open for others.


(Blake Bartlett) #5

It would help to get a picture of your actual output.


(Brandon Brooks) #6

Yeah I know. My phone died a week ago and the new one hasn’t arrived. I’ll try to bring a sample to work tomorrow to get a picture with my webcam.


(Brandon Brooks) #7

WIN_20190613_09_32_31_Pro

This is what it is doing. The laser is actually stopping in the middle and traveling to the other side. The preview doesn’t show this.


(Oz) #8

What speed do you have the fill set to? (and in what units? mm/sec, or mm/min?)

What speed is the controller limited to in the settings? (type $$ in the console, look at $110 and $111)

If it’s shutting off in the middle of a long run, that usually means that the controller is trying to go faster than it is actually allowed to go, and so it’s reducing the beam power output to compensate for the lower speed that it can achieve, so the amount of power hitting the material is what you’ve asked for.


(Brandon Brooks) #9

I’ll take a look when I get home and adjust those settings. I was fiddling with those settings quite a bit to figure out what I could do. I didn’t realize it would effect the power output, but that makes sense.


(Brandon Brooks) #10

$110 and $111 are both set to 1000, which is the recommended setting from Eleksmaker. My burn settings are:
Mode: Image
Speed: 5 mm/sec
Max Power: 100%
Image mode: Threshold
DPI:254

I have also turned the image into a outline with fill settings at the same speed and power. Both modes give me the same result.


(Oz) #11

Have you tried any other software? I feel like this is a hardware or device settings issue, but you’ve posted relatively little about either, so it’s hard to pinpoint what it could be.

When running a generic vector fill, LightBurn uses G1 Sxxx to move with the laser on, and G1 S0 to move with it off. It doesn’t get much less complicated. If you draw a circle and set it to fill with the same settings, what happens?


(Brandon Brooks) #12

I’ve been using this laser with Benbox for 4 years with relatively little issue. I’ve been using lightburn for my k40 for 9 months and love it, so I wanted to switch over to using the same software for both. That might not be an option, but I thought I would give it a shot. I’ll try a simple shape tonight.


(Brandon Brooks) #13

Another day and numerous tests later. It seems to work fine as long as I have the “low beam” button turned on. This is for focusing the laser and is supposed to stay off to lengthen the life of the laser, but pushing that button in fixed the problem mid-burn. No clue why, but it is functioning as I would expect. Any thoughts?


(Oz) #14

No - that’s very odd. Possibly some kind of electrical interference, but I can’t see why that would be.


(Brandon Brooks) #15

I probably need a new controller card. The current one has been my controller for probably 2 years now. I think I even have a spare somewhere. I’ll swap things out to see if it goes back to normal, but regardless, it is functional now.


(system) closed #16

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.