Fill + Line issues not cutting in the same area

Hello all, hope everyone is great during this time of lock down. I have a question concerning the fill and line not matching. the fill will eat it out and then the line is way off. From the looks, the fill appears to be the appropriate amount so I do not think it is under burning or over cut issue. I tried to replicate the issue on an individual star and I could not. I seems as if the problem is coming when I upload the file to the ruida controller and at the end of the run. When I did individual stars, all was good. I attached a photo for your review. Right now I am burning at 100 mm a sec so not overly fast. But as you can see the line is exactly to the right of the fill. Any advise would be great.

Thanks and have a great day!

strong text

If you engrave a single tall, thin rectangle, with Fill + Line, does the rectangle slant off to one side? (Do the stars?) or are things just shifted?

If the items are just shifted after the engraving pass, it’s most likely that you’re losing steps somewhere due to your speed or acceleration being too high.

If the shapes are actually slanted / skewed, that’s a different setting issue, in the vendor settings, called “PWM rising edge valid”.

Is there a difference between speed and acceleration? I burned a thin tall rectangle and it did not appear to slant to one side and the line was perfectly placed on top of the rectangle. I have done individual stars using the same file and it seems to work fine. When I send the image to the laser and then start the burn what you see above occurs. Is there a possibility there is a star which is offset that I can not see. Grasping for straws here.

Thanks,

Wes

Under “Machine Setiings” -> “Cut Parameters”, what are your idle speed and idle acceleration set to?
Those are the speed and acceleration settings for how fast it moves (and accelerates) between cuts.
You might try nudging the acceleration down some and see if that helps. Probably not, but it’s the only straw I’ve got for you to try…

There’s also 'line shift speed" for how fast it moves between cuts when in an engraving pass, and Y acceleration, though this looks like a shift on the X axis. Idle speed and Idle acceleration would be my bet too.

Because I am new to all of this, I have taken a screen shot and posted it here. Do you see anything that stands out anywhere which could be an issue or just something I should change overall?

Thanks for all the help,

The X acceleration of 8000mm/sec^2 seems rather high to me, but nothing else stands out. Turn that X acceleration down to 4000 and see what happens. If nothing changes then put it back.

I agree with Hank - try 6000 and see if that makes a difference. The X & Y start speeds seem a bit high too, but it really does depend on the machine you have. If it’s light and has strong motors, these might not be an issue at all.

So if it is not losing steps any idea what else would cause the exact offset of the star when doing fill + Line?

I adjusted the speeds and I tried it again and as not to have to start all the way back over with wood prep I removed the line so I did not even take the chance. This time two of the stars above the patch are skewed and the patch is not centered. On lightburn it is perfectly centered and the two stars do not look incorrect. I have attached some photos. Any ideas?

Now this is getting frustrating as the issues change.

Thanks

Uploading: 2043E741-F21F-4AC0-BC39-F6196E9A1E07.jpeg…

And acceleration? What is that X acceleration currently set at?
If it looks good in preview, but is misaligned when cut, you’ve GOT to be missing steps somewhere, somehow. Does the gantry and carriage move smoothly with no binding?

Okay after a load of testing I think it is more a software issue. Not sure if it is the Ruida or a LB thing. I have tried Fill all shapes at once, fill groups together and fill shapes individually. The only one which will produce the star without bent points is the fill all shapes at once. Unfortunately, this setting takes four times as long to complete. What would cause only two stars to have the points burned incorrectly. I have tried replacing the stars and that did not work. I have change the speed to extremely low and tried the fill groups and fill shapes and that did not work. I even tried flood fill and still the only image which was correct was fill shapes at once. I turned the acceleration down and still a no go. Any more shots in the dark?

Thanks again for all the help

I can assure you it is not a software issue - if it was, everyone would have it, not just you.

You did give a clue though - “Fill all shapes at once” is going to have the fewest travel moves between filled shapes. Your X acceleration for engraving and X-Start speed might be too high in the engraving parameters. Try setting these:

  • X Start Speed: 10
  • Y Start Speed: 10
  • X acceleration: 6000

Oh Lordy… my 500 x 700 Red&Black would never tolerate 6000mm/s^2 acceleration. I’d probably start with 4000 and work my way up.

OZ, I think I offended and that was not my point. I did not mean lightburn was messed up I meant my settings in lightburn/ruida were screwed up. I will try the adjusted speeds when I get home from work. Why would only two stars of all the stars be skewed?

I do appreciate what you do and the information you provide by the way.

Thanks,

It’s ok - I hear that enough (“I’m pretty sure it’s a software issue”) that I’m rarely offended by it anymore, it’s more my way of saying, “no, I’m quite sure that’s not it”. :slight_smile:

The things that cause misaligned cuts are:

  • Acceleration too high
  • Speed too high
  • Motor current too low
  • Resonance
  • Mechanical play in the motion system (loose bearings, belts, pinions, debris on the rails)
  • Material movement
  • Communication errors

The first three are inter-related. You can take two identical machines, and on one of them, if you lower the motor current, the acceleration might now be too high. Steppers lose torque at higher speeds, so the faster you go, the lower the acceleration needs to be.

Resonance is something that very few people pay attention to, but complex paths with lots of jumping around can easily cause it, even if you never have a problem with the machine when running simpler jobs. Watch the video linked in this post:

Basically if the motion system has momentum in one direction, and is stretched a little, and you change direction at just the right time, it will skip.

Just wanted to update this thread. The last suggestion with slowing stuff way down on X and Y along with acceleration seemed to fix the issue. For the life of me I don’t know why it worked at one time then started to fail. Oh well fixed now!

Thanks again for all the input.

Wes

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.