Fill+Line Issues

I’m not sure what is going on with the Fill+Line issues I am seeing. At first I thought maybe I’m loosing steps but I burned a tiny spot at 0,0 and then when done returned to 0,0 and was right on. As you can see Overcut and Kerf Offset are both set to 0.

Some things I do with Fill+Line I don’t see this issue with the same settings, looks the same as if I did fill only.

Below are images of what I’m seeing, clearly the line pass is outside of the original vectors. If I was loosing steps the outline would be all to left/right or top/bottom but they are not.

What am I missing here? The more I look at these images wondering is the fill not completely “filling” do to my settings?

Any help would be great, this is a DIY build using GRBL.


Fill only:



And same thing happing with just text:

Which version of LightBurn are you running? Does this happen only with more complex designs? Like, if you engrave a square with FIll + Line, does it happen there too?

You said, “it can’t be missing steps because it returned to zero” - Zero is butted up against the limit switches, so if you lost steps while moving away from the origin, you’d return too far, but the limits would prevent that, and you’d stop where you started. If you started the job somewhere other than the 0,0 point (using User Origin) that would be a better indicator.

Will try a square. And when I did my return to 0,0 I DID NOT HOME, I have a lot of experience with DIY CNC routers since about 1998 and yes homing will always bring me back to 0,0. Also I thought let’s turn down speed and acceleration and what I see is the beginning of X and ending of X isn’t really doing any burning (scan angle of 0). Looks like LightBurn is taking acceleration into account but maybe too much. I might be wrong here and hope I hope I don’t have to set my config to meet software needs rather then my physical machine needs.

Sorry I’m using .9.11 just purchased and yes was user origin.

That’s not LightBurn, it’s the controller. Enable overscan on the engraving and it lets the controller overshoot the engrave while still moving, so you get a much more consistent burn.

If you are using a CO2 laser, you’ll have problems with GRBL - It ramps power down to zero when the controller hits a dead stop, but CO2 lasers have a threshold where they start firing, usually about 10% of the tube wattage as a ballpark. The higher versions of GRBL, like GRBL-LPC (for 32 bit chips) have settings to adjust the low-end PWM output to handle this, and DSP controllers give you this control per cut, and LightBurn exposes it, but GCode systems don’t have a way to set it.

Nope using a crap china diode laser also seeing parts of other test missing but looking at gcode with a gcode viewer lightburn is sending the correct code (showing laser power where spots are missing). I did try a small square and outline worked fine. The more testing I’m doing I’m thinking that it’s not the outline being too far away from the vectors I’m thinking it’s the fill not being completely filled. I apologize I don’t think this is a lightburn issue

Overscanning fixed all issues! Thank you! using 4%. Thanks for the quick and fast support!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.