Fill mode in lightburn

Hi to all, I have had a xtool d1 pro 20w for about 3 mo. started out working fine but now will burn skewed
in fill mode at any speed, offset fill works fine and xtool creative space burns fine. Any ideas?
See pic below. Thank you

I don’t see how it could possibly be a software issue. It seems you’re comparing apples and oranges. None of those tests are doing the same thing at the same speed. Speed numbers alone are also meaningless without units of measure.

Ok i should have clarified the speed. it is mm/m for lightburn and mm/s for xtool creative space
i have also checked the belts and the set screws on stepper motor

Also the laser is very jerky in fill mode and runs smooth in xtool creative space.

Can you upload the file you’re using for testing?

Here it is i hope i did it right. Thank you
test burn.lbrn2 (72.2 KB)

I don’t see anything in the design that would cause this.

Seems to me an issue of skipping. So something mechanical or electrical but question is why.

Make sure your belt tension is good. Other than that I’m wondering if this might be a firmware bug.

Ok i will check belts again. and you are the expert but if it were firmware would it work in xtools software
and not in lightburn?

xTool have a dual firmware model so LightBurn works in GRBL mode and XCS works on their own proprietary firmware. xTool has struggled with bugs in their GRBL implementation. I’m not sure about their internal firmware.

Ok i have updated the firmware, double checked belt tension, set screws and cleaned the rails and rollers
and am still getting the exact same results.

Can you try running these two g-code files and confirm you get the same issue?

test.1000mm_s.gcode.txt (49.9 KB)
test_300mm_s.gcode.txt (49.9 KB)

I will try that when i get home going out of state for a funeral.
Thank you

Ok i am back, ran your file and it worked perfectly. so i tried my own again with the same results.
here is the file i ran.
test.1000mmsgcode.txt (67.6 KB)

Go to Device Settings. Disable or reduce Fast Whitespace scan dramatically. Retest.

I disabled fast whitespace scan and still get the same results.

Can you regenerate gcode?

Also, take a screenshot of Device Settings and Move window. I may be missing something.

If you need more please let me know

test.1000mmsgcode.txt (67.6 KB)

Somehow you’re getting feedrates of 90,000 mm/minute occasionally throughout the gcode. That’s surely what’s causing your motors to skip. Can’t work out why.

Try a few things:

  1. Can you take a screenshot of Preview with “Show Traversal Moves” and “Shade According to Power” enabled?
  2. Can you enable “Fast Whitespace Scan” and set to 1000 mm/mm. Then retest.

I think somehow LightBurn may still be using the disabled whitespace scan value.

Ok it looks like you were right on. I reset the fast whitespace scan to 1000 mm/mm retested and it works
perfectly. not sure how it got set so fast but it works now so i am very happy!

Thank you all!!!

1 Like

And did you leave it enabled?