Fill Problems on Marlin Board

I am having trouble with the fill feature, I can do line engravings but fill has problems. It seems like the laser isn’t turning on/off at the right time. Is there any way to automatically adjust the gcode to make things work?
I am using M106/107 to control the laser

New user myself, but I saw the same thing and lowered my speed and it went away. Engravings looked like smeared paint.

This is an unfortunately common issue with Marlin. I believe by default they ‘ramp up’ their fan output, which is generally where the laser is connected. There’s a compile-time option to disable this, but not one that you can just set from the console. You need a different build of the firmware with that fan ‘soft start’ ramping feature disabled.

This is one of the reasons I loathe Marlin - many options can only be changed at compile time, and there are hundreds of options - the firmware is so endlessly configurable that it’s next to impossible to actually support it.