Fire and Frame working together

Hi all,
I love the test features that allow me to fire the laser in low power to focus it, and the frame feature that moves the laser head to verify the selected objects. I wish though that the frame option didn’t turn off the laser. I enable fire, and then frame, and the framing always disables the laser. Would be much more effective if the laser stays on in low-power mode to allow be to more accurately see the path traced.

Is there a way to configure it to leave the fire mode on during framing?

Thanks,
Kevin

Hold ‘shift’ down and press ‘fire’ button

Sorry my mistake, hold ‘shift’ down then press ‘frame’ button

1 Like

Thanks will try! Appreciate the tip.

I have a Sculpfun S6 Pro that I just received a couple of days ago. I downloaded and installed LightBurn on an old HP laptop runniing Win10.

When I hit “shift” and hold down the “frame” button my laser doesn’t fire. I try to run a test design and the laser doesn’t fire. I’m sure I’m doing something wrong.

Having all the windows stacked up is a little confusing at first, but I’ll get used to them.
I just afraid that there’s something wrong with my laser module or MB.

Thanks for any help!!

Randy

Try holding down the ‘shift’ key then hit 'frame, not the other way around

@Itmservnet If you don’t have the Fire button enabled this may not work.

Check out this previous write-up for a broader explanation.

I tried with the SHIFT key and it worked. My question though is, if FIRE is on, why would Lightburn turn it off for the frame operation. That seems like the wrong behaviour. Is there a way to change that behaviour?

Glad it worked for you. I can’t answer your question that would be one for the Lightburn team. As far as I am aware there is no way to change this, not that I have found anyway !

I’m not a LightBurn developer but thinking about what you would want the frame/fire to do it makes sense what they are doing. The laser position can be anywhere, including over reflective materials so when the frame/fire is triggered, they make sure the laser is off, move to the object framing area, then turn on the laser. Ending with the laser turned back off.

I see your point about when you have manually engaged the Fire button and YOU assume all responsibility for where you move the laser head. And the laser does currently continue firing while you move the laser head around on the build area.

I suppose they could have a ‘setter’ and ‘getter’ function on the Fire button activation and test it before starting any frame operation and then disable the “turn laser off” elements of the framing operation.

Feature request?

‘Fire’ does not need to be ON when you choose, press and hold a SHIFT key, then choose a frame button (either square or rubber band). It starts at low power as soon as this sequence occurs.

  • you can turn the ‘fire’ button ON,
  • align to a reference mark, or a start point,
  • turn it OFF (the fire button)
  • then check to verify everything will work as you expect.
  • if you want to make really sure your expensive work material will burn as planned …
  • Frame it again using the shift-frame feature and verify your job.

It all depends on your workflow, and the tools you have to use.

@JMichael , This user knows that and said so. I suppose you two can debate why it should or shouldn’t turn off the fire button when framing(either with or without the Shift modifier). I’ll grab some popcorn and watch as personally I’m fine with the current setup except I want better hotkey support for those two Shift modified framing buttons.

yeah, I get that … I just don’t want another ‘feature’ that just bogs down an already quick responding, well designed software.

I agree … it’s fine the way it is.

1 Like