First "Move" after startup jumps to Y:420 (just the indicator, not the laser)

When I start up Lightburn it homes automatically, (finally got the right settings in x and y inverts)
but my first “jog” with the move button jumps the laser indicator to 420 in the Y direction. then it moves 10mm correctly after that.

Shouldn’t the “show last position” indicator cross-hairs reset to home when I home it out?
I try to frame an object and it just skips steps trying to go lower Y even though its hitting the limit switch. it homes just fine, double bounce, no skipping steps.

Again, the laser moves 10mm in the correct direction with move buttons, but it thinks it is at Y420 after
the first move. So when I try to frame, it maxes out on the back stop, making a terrible noise.

I have a NEJE master 2s max laser engraver / cutter with N40630 module - 460 x 810 mm - laserGRBL - lightburn …

Thank you for any help, I am new, but I have googled for an hrs trying to find a solution. Now I have narrowed down the problem but can’t find a solution.

Found this Belt skip and jumping machine when FRAME is selected - #3 by Sunwriter
but a little scared to type in $RST=$, without knowing what I’m doin.

I used this machine when I first got it and it didn’t have this issue, so maybe resetting the firmware will fix it.
I got this a month ago then couldn’t play with it anymore until now.
I did have to unplug it a few times while it was trying to home in the wrong direction maxing out. and skipping steps.

Well, I learned how to back up all my $$ (lol) I have the Arduino IDE and am familiar.
after giving the $RST=* command in the lightburn console, then restarting LB, it only jumps to Y150.
So I am half way there?? lol.
Sorry I am impatient, but I won’t stop until I get this figured out.

same problem, just now it is Y150 not Y420. I checked my work area size(made a new device too) and also there is no offset (tried adding it but didn’t fix)

thanks for any help, I’m new but love to learn, and have already learned a ton.


after I reset stuff I called $$ and noticed my $131 (Y MAX travel) was at 150.
so I set it to 200, ($131=200),… and restarted LB. sure enough, it now jumped to 200 on first move.

So I $131=0 and now it works perfectly. So issue fixed but I would like to know WHY?
$130 is 810 and it works fine. My Y is 460mm, that should be max travel, right?

I just LOVE learning all this stuff!! At least I can start cutting and engraving now, and I have learned a lot, but that shouldn’t be the solution, it feels like a band-aid.
more info would be great. thanks

So nobody has replied, maybe this is the wrong section, but let me try to explain my issue and “fix” one more time.

When I start up LB my laser homes just like it should,(top left, on my machine) then I would push the move button(down or right) and the cross-hairs showing where my laser is, would jump to a big Y number(whatever my $131 (Y MAX TRAVEL) is)

My $130 (X MAX TRAVEL) is at 810, and there is no issue with X axis.

When I set my Y MAX TRAVEL to ZERO($131=0) then everything works just fine.

But I feel like this is a hack and not fixing the problem. Would love to know why the X max travel is cool at 810, but my Y max travel needs to be zero.

Thanks again, I posted this in the “getting started” section(bc I’m new) but soon learned about $$ and so this question prob needs more advanced users. If nothing else hopefully it will help somebody in the future.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.