First time user set up

ive got a Xtool D1 pro, ive gone through the set information more than once but i still get the same error when itry to frame or start,
( there was a problem sending data to the laser
the machine may be busy or paused) ive checked all the requiered conections all seem ok.
in the Laser it say’s READY.
The Laser has the red cross showing and the power indicates on ???

The Console window in LightBurn is the best way to determine whether or not the xTool D1 Pro is connected to LightBurn.

Be certain that XCS is closed in Task Manager as some folks have seen it persist after closing it. The shortcut is Ctrl-Shift-Esc.

Since you’ve gone through the setup information please confirm that you’ve:

  • Downloaded the Ch340 driver.
  • Imported the lbdev file from the xTool website into LightBurn.

After that, open the Laser window and the Console window in LightBurn. If you see no connection messages in the Console window, click the bottom middle button in the Laser window and select a different USB port.

Wait 10 seconds or so and if you see no connection message, attempt to select another port until those options run out.

Hi John John
Thanks for your help, i followed your advice and changed to a different port but still with the same result, were do we go from here??

I would begin with the most recent serial driver from the manufacturer of the communications chip.

Please download and install this, as administrator if necessary.

downloaded the serial driver as sugested but with no joy, i’ve checked all the conections outside and in all seam secure. when i tried to frame the laser head made a very minute movement, do you think the laser could be out of position somehow and wont move because it’s close to crashing. nothing has happend since then.

is there anyone out there that can remotly connect to my computer to try to find out what’s wrong

With the driver installed and LightBurn up and running, retest the communication ports by selecting them one at a time in the Laser window and watching for a message in the Console window.

The xTool D1 Pro should autohome on startup. if it doesn’t the settings have been adjusted or there’s something more serious wrong with it. A power supply that’s not fully plugged in or connected could be responsible for a slight movement then a sudden stop. Stepper motor cables can go bad or break near the crimp causing the behavior you describe.

ive dissconected and reconnected all the cables, but i still get the same error, if i move the origin to the centre it says -cut might be out of bounds- how can that be i’m set in the centre of the working area it’s only 100mm round, but i still don’t think that’s anything to do with comunication.

If you didn’t use the jog buttons in the move window to move it to the middle of the window the movement wouldn’t be counted.

If the movement was counted you can see the reason for that message in the Preview window. Turning on the Show Traversal Moves switch at the bottom will show all the moves that the engraver will perform. The laser will be on for the black lines/moves and off for the red lines / moves.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.