Flame Check on XTool

Setting up a new XTool D1 10 watt. Getting frequent “Flame Check” alarms. The console shows:


Cutting 3mm plywood on a honeycomb working table with air assist going and a table fan as well. Speed/power = 5/100. No flame is visible.

o Why is this occurring?

o Can flame sensitivity be lowered?

o Can the flame alarm be disabled?

o How is the alarm shut off, other than by turning off the tool?

o Can the job be continued from the point at which the alarm occurred?

Thanks for any help.


@Anwen - Any thoughts on this behaviour?

My new D1 Pro worked normally for a few days (I know because my son has one too), then started throwing flame checks on every job, including ones that worked fine previously, Even happens on stone and slate with power turned way down. I have all the same questions Roger. Dead in the water for now…

Got in touch with XTool. Flame alarm can be set to
“High Sensitivity”,
“Low Sensitivity”, or
“Do not show again”

Changes must be made thru XTool’s proprietary XCS software. Click Gear Wheel>Materials.

Jobs cannot be resumed after alarm.

I’m been OK for a few days now running at “Low” setting. But I can’t now make the system fail at “High”. Is my system flakey or am I missing something?

PS: I want a working legitimate flame alarm.

1 Like

Roger… Great tip; it solved my problem, using the Low setting. Good to have a working integrated smoke detector that turns the laser off, I agree. Another safety option is to get a standard battery powered smoke detector and mount it as close as needed. At least you would get an audible alarm if things got out of hand.

Jack… Happy that got you going. And great the Lightburn supports this forum.

XTool also said the changes persist over power cycle, so you don’t have to redo them each powerup.
They won’t release the GCode to do the same thing thru LightBurn…have to use XCS.

I am not sure I understand, if we do the update will we still have the problem if we are using Lightburn.

I have also read that folks with the Pro-series xTools have gotten flame alarms when the machine happens to be in direct sunlight. I think that that the sensor is looking for more than just smoke. It is sensing heat and light as well. So it may be prudent to keep your machine out of direct sunlight from a window or other opening to the outdoors.

It is my understanding from XTool that when Flame Alarm status is changed by XCS if stays changed. LightBurn will see to new status. A repowered XTool still has the new status.

Roger… That seems to be my experience as well. No false flame alerts to six days now, with the D1 turned on and off many times. Again, thanks…Jack

How do you get at that software?

XCS is free software supplied by XTool for their hardware. Check their website.

Have xcs loaded, cannot find how to get to the menu that lets me set flame sensor sensitivity

Click the gear icon at the top right, next to your laser. Next click “Working Parameters” then set the flame sensitivity where you want it, “do not show again” turns it off.

It just happened to me this morning. Sitting in the garage with doors wide open and the machine in direct sunlight. Kept getting alarm check and could not figure out why when it worked fine the night before. Came here and read"dpiekarksi" message. Closed the doors and the alarm stopped. Am a happy camper now.

Mine was throwing the error during framing! Your response solved it for me… I had the garage door up and it’s a very sunny day, put the door down and no more error! Fortunately, my enclosure is being delivered today. Thanks!

Thanks John
I turned it off and in business now
I don’t have any light issues or reflections so will work on it when time permits