Flash rouge et vert après mise à jour firmware + axe Y ne fonctionne plus

Bonjour, sur un OLM3 j’ai eu une série de problèmes (logiciels et mécaniques) que j’ai essayé de solutionner en changeant la carte mère pour repartir d’une base neuve. J’ai souhaité mettre à jour le firmware et depuis la led clignote rouge et vert en alternance, en outre le laser se déplace sur l’axe X mais plus du tout sur l’axe Y. Je me demande si le moteur de l’axe Y n’a pas subi un dommage irréversible.

Hello, on an OLM3 I had a series of problems (software and mechanical) that I tried to solve by changing the motherboard to start from a new base. I wanted to update the firmware and since then the LED has been flashing red and green alternately, and the laser moves on the X axis but not at all on the Y axis. I wonder if the Y axis motor has suffered irreversible damage.

Those stepper motors are fairly tough. I doubt if you harmed one.

I suggest you consider a (1) broken wire, (2) bad plug, or (3) bad driver chip on the controller board, in that order.

Thanks for your reply, I just do not understand “bad driver chip on the controller board”

Here is a link to download a small movie showing the defaults. Blinking blue red and green, bad calibration of the laser zone. https://we.tl/t-UKiqSek0fZ

I could not view the video, but blinking lights would mean nothing to me. I have no experience with your model laser, so I will let someone else join in to help.

Check if you have a switch to rotary on/off.
Also recheck if all plugs are well seat.
Other things to try: Check and Insert SD card
If the problem persists try switching motor cables at motherboard plugs to see if the problem moves to the other ax.
Additional info:


Check if the laser is still in upgrade mode.

Thanks, I try this

I have the feeling the laser is stil in the upgrade mode. How can I quit it ?

It is quite strange : I switched the cables ont the motherboard and it is still moving on the X axis only !

It works… a little bit. I checked the cables, and the Y axis worked when I put on YRR Motor (!?). But now I get an alarm2 and it stop after 2 minutes

Did you changed any settings?
Read this explanation of alarm 2

Thanks a lot for your help. If I keep my working area in a 400x400, it works, whereas I have a 400x800 extension kit correctly set in the settings. If I ask the laser to work on a 400x800, alarm 2 appears after a couple of minutes working. Thanks anyway I will check this asap.

On Lightburn Console window type $$ and copy/paste here the output.
Likely your controller GRBL settings, $131 is incorrect.

Thanks for your help, I am not at the office today, I will do it tomorrow

1 Like