Focus test problem with tiny frame area

HI all, I previously ran a focus test before doing a manual focus first to get in the right range. When I run the focus test now, and check the frame, it is very tiny, maybe 2cm x 2cm, whereas the first focus test was like 6cm x 3cm. I don’t see a way to change the frame size so I assume I must have messed something up somewhere. Any suggestions on where to start with this?

The frame size of the focus test varies with the number of steps. If I only do 5 steps, I get this:

image

…but if I do 20, I get this:

image

Hi Oz, thanks for the info. I do have the number of steps set to 20 (the default I believe.) I had changed some of the grbl settings and am in the process of setting them back to the mfg defaults. I’ll reply back if that helped or not.

OK, I set all of the grbl settings back to factory and that fixed the tiny scaling issue. I’m struggling with which one(s) “fixed” the issue because now I have the opposite problem. Everything is now using MUCH more area including the focus test. For example I have a drawing that’s 121x101mm. I set the origin after placing the laser at essentially 0,0 (bottom left). The drawing shows the red and green squares overlapping in that position and the drawing bottom left is placed at 15,15 . When I use the frame tool before burning the drawing, it moves completely to the other side (width) of the machine table which which is 300mm wide and 180mm high. I have to stop it before it reaches the physical limits. I have no idea what could be causing this. Any help would be greatly appreciated. If it helps, here’s a list of my grbl values:

$0=10
$1=25
$2=0
$3=0
$4=0
$5=0
$6=0
$10=1
$11=.010
$12=.002
$13=0
$20=0
$21=0
$22=0
$23=0
$24=25
$25=500
$26=250
$27=1.00
$30=255
$31=0
$32=1
$100=1600
$101=1600
$102=1600
$110=1000
$111=1000
$112=800
$120=30
$121=30
$122=30
$130=200
$131=200
$132=200

Change $10 to 0, not 1 - that might be all it needs. When you manually set zero you’re setting a workspace offset, and the $10 parameter controls whether the board reports its position in absolute machine space or workspace (you want them in workspace).

Awesome, thanks for checking this! I’ll try that asap and let you know how it goes!