Focus Test questions

Windows 10, Ruida controller Boss 1420. LB Version 9.11

Sorry if this has been ask and answered before, but the Focus test software seemed to be changing a lot and I am not sure which threads are still accurate.

So my first try at the focus test with the 9.11 software did not work because I did not have the Enable Z Axis switch turned on. So I found the switch (under device setting) and turned it on.

Then I ran the focus test again with Start Z at 0 and End Z at .2 thinking it would be relative to the current Z position. Nope it tried to bring the Z axis to 0 which crashed it into the head. OK, my bad. It appears that the start Z is the actual Z position to start at. So I set my focus and manually and clicked the Get Position button. That tells me my Z is at 117.434 (not sure what units, I have units set to inches but that seems way to big for inches)

image

Then I opened up the Focus test again with the intention of setting the Start Z value to 117.25 and End Z to 117.65

But the Start Z data entry box will not allow me to enter more than one digit to the left of the decimal. I give up, whats the right way to do this? (without crashing the head again)
image

You’ve got something else going on. Make sure the “relative z moves” only is checked. Home you machine and then tell it to get the z position. It should be 0.

I use relative Z moves only myself. Annoying thing about the focus test is that it won’t let you enter a negative value for the start Z. So If I think my focus is at 5mm Z height and I want to test either side of that I have to move my Z up first then run the test so that it steps down and through the 5mm.

Do you run everything in inches instead of mm? And I I recall you have an autofocus probe, correct?

Ruida itself won’t allow me to issue a negative Z move, if you’ve zero’d the machine with an auto-focus.

The simplest approach here is to move the laser to the point that it’s touching your material, or a known height above it, then using relative Z moves, run a focus test from 0 to (something). The narrowest resulting line will be the amount you add to the initial height to get proper focus.

Alan - your height of 117 is probably accurate. Ruida initializes the Z axis to 3000mm (118.1") if it’s not zero’d.

Oz, what if I’m not using auto focus? I removed my auto-focus probe a long time ago. When the machine starts it raises the bed to the limit switch and sets that as Z zero. I know my focus will be around 5mm. So instead of being able to set my bed to what I think the focus is when I start to run the focus test I have to move it up. Is there a reason I can’t use a negative start position without the autofocus?

The biggest reason is that I don’t know until you hit ‘Start’ whether your laser will allow the negative values or not. If you’re using relative moves, it would work. If you’re using absolute moves, it won’t. I could actually check for that setting and allow negative if you do have relative enabled, but if you have an auto-focused machine, I don’t think the system will travel below the zero point.

It’s only a slight annoyance since I developed my own focus test for fine tuning but I do like to use the focus test for rough adjustment. I have no autofocus, I use relative z moves only, but it will not allow me to enter a negative value for the start z on the focus test. Ruida 6442.

@Allen one more question, do you even have a z limit switch or is the autofocus probe your only z switch?

So I should Enable Z axis AND enable Relative Z moves only. Is that correct for Ruida?

Yes, that’s what I recommend in general - it prevents the head from crashing.

Thanks, good to know.

I just did an auto focus and now the Z is returning a value of .76. Does that mean the focus test should run from Start of .76 to End of .86 (or other small distance from start)?

You could run the focus test from 0.5 to 1.0 assuming you have the room to do so. The 0.76 could be the focus offset in your machine.

Just my 2 cents, but if you have a z limit switch (not the autofocus probe) then I’d get the probe out of the equation entirely. You’ll find life much easier.

I just tried the Focus Test without a bed in the machine to prevent a head crash if anything went wrong

I auto focused the machine and got position. Z was at .76

I set start to .76 and End to ,86 (this was before I just saw your last response)
Relative Z Only is enabled

I started the test and the Z table moved up and down about half an inch many times (maybe 6 or 7 times) with the X and Y not moving.

Then the Z moved up about half an inch and them back down about half an inch and the head moved like it was engraving the first test line.

Then the bed moved up and back down again (still moving about half an inch) and it did the second line. This large up and down movement would have continued for all test lines but I stopped it.

I have no idea why it is making such large movements during the test

@Allen Edit>Device Settings>Optimize Z moves. Turn that on.

Oz, I’ll also note that - values for Z offset in a color layer work which is how I managed to design my own focus test. But they work backwards.

Thanks, I did not have optimize Z turned on. What exactly does that do?

At the risk of coming across the wrong way, it optimizes the moves, ie, it only moves when it absolutely has to. For example if it moves down 1/2" and the next move is also to be down to the same spot, it will not return to zero between moves.

1 Like

So without the optimize it needs to find zero before each move. That explains all the up and down it was doing before I optimize turned on. Thanks

1 Like

Yes, in case you were engraving something like the bottom of multiple little boxes with walls, it would move back up so it didn’t hit the wall when moving from one box to the next.

1 Like