Focus Test Z Height Starting value

I want to test out the Focus Test and I am very very paranoid about crashing my head due to entering the wrong Z height. If I do a Get Position, it says my current Z is 2963.44mm. This value is about 15-20 mm above the material. What value should I put in the StartZ and EndZ if I just want to test a +/- 2.5mm range around my current z height setting?

Okay, I took a chance, moved my head far away from the table and hit Start with one hand on the power off button. Looks like StartZ and EndZ values are relative to the current value. One thing I noticed though is the Z height table seems to re home for every line or segment with these settings as well as others
Start Z = 5, End Z = 5, Speed = 50mm, Min/Max power = 30, and Step 5 = 5.

So when drawing 5.0, it vertical re homes to 3000, draws “5”, vertical re homes to 3000, draws “.”. Removes to 30000, draws “0”, then vertical re-homes and draws line.

Is this expected?

Fixed it. Looks like in LightBurn, Device Settings, in addition to “Enable Z Axis”, Also set “Optimize Z moves”

Awesome, this makes it so much easier to re-calibrate after cleaning lens/mirrors. My manual testing on my Boss showed I needed about 7 mm between material and the the tip. This gave me 6.5mm which will make a difference for the inlay and graphics work I want to do.

Steps I used in case someone else needs it

  1. So I set my height to 4 mm (within 0.25mm) above material. Z position was 2938.77
  2. Went to Focus Test
  3. Start Z = 0
  4. End Z = 6
  5. Steps = 12 (0.5mm steps)
    6 Power = 20%
  6. Make sure Enable Z and optimize Z are on in device settings
    8 ) Hit start.
  7. Test then started at Z = 2938.77 (4mm above material)
  8. SW Ran 0 Line, dropped the table 0.5mm to 4.5mm and Ran 1 Line, dropped table another 0.5mm to 5mm above material and ran line 2, etc… (took a few seconds)
  9. Looking at the lines, 2.5 had the thinnest line.
  10. My new z height is now 4mm + 2.5mm = 6.5mm from the material.
  11. Disable "Enable Z Axis"and disable “Optimize Z Axis” in device settings.

For clarity in your workflow, why are you turning those OFF again?

So I don’t accidentally engage the z control and crash my head and break who knows what again. I crashed my head a couple months ago(my fault) and broke a bunch of stuff. So I am “beyond paranoid” about anyone or anything playing with the Z. :slight_smile: I sometimes forget I have done things so I try to make sure I put things back where I found them. Sorry for long answer. :slight_smile:

The next release of LightBurn actually supports real and proper relative Z moves, which makes it less likely to crash, but it’s still a good idea to disable the Z completely if you’re not using it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.