Font welding and single line fonts

Trying to use a single line font and getting the disappearing text issue (especially if text includes “A”, “J”, or “R”). Turning off welding as suggested by Oz at Simplex or line-type font works, but the problem is that it turns itself on by default when you select the Text tool. You can deselect the Welded slider, but as soon as you click in the drawing area to start typing, it reenables. The only workflow that I can think of to get around it is to type with welding enabled (if you can see what you’re typing), then switch to select tool, select text, deselect welding, and if you’re not done typing, select the text, position the cursor, and keep typing. I believe I’ve even seen it spontaneously reenable while I’m typing.

Is there a setting I’ve missed somewhere to make LB content to leave welding off, a bug, or both?

Also, how is SHX font support coming along? Almost anytime I import external graphics rather than draw in Lightburn, it’s from CAD, so SHX support would be a good deal for me.


The weld issue has been fixed for the next release - single-line fonts are detected automatically and weld is ignored for them, and the issue of weld changing state, and a number of other issues similar to that with bold and italics, are fixed as well.

SHX fonts are working for non-unicode fonts, but a bunch of other infrastructure needs to go in to support them - namely integrating them with the font chooser, size normalizing, and setting up the prefs to let you choose where to find them.

Sweet! Thanks for the quick reply!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.