Fonts and Shapes do not connect after laser cut

grbl

(andrew manus) #1


(Rick James) #2

You have “sainsmart 3018 Pro” listed as your machine. I am not familiar with this system, the type of laser nor the controller/firmware used to drive it. Please provide this information.

In general, it looks like the laser is not firing as it slows down for a direction change, indicating you have the ‘Min Power’ set below the fire point of your laser. What settings do you have for this layer?


(andrew manus) #4

Thanks Its the GRBL software using the woodpecker 3.2 control driver board, as a Note lightburn was running correctly at one time I don’t know what I changed or how I changed it but in the Picture is what I am getting now
My Trial runs out in about two days, Laser Engraving a Picture is Working Fine, I must have changed something ?


(Rick James) #5

Please post a screenshot (not cellphone pic) of the settings for this layer along with your Device and grbl settings.


(andrew manus) #6

It is now cutting the full letter But now the Laser is not cutting Off when moving to the Next Letter
Andrew Manus


(Rick James) #7

You still have not told us what version of grbl you are using and its settings. We can’t help you if you don’t share this info. :slight_smile: This is most likely a grbl/LightBurn setting mismatch, but until we can see those settings it is just a guess.

For grbl 1.1f and later, check your setting for $30 and $32 in the console by typing $$ and pressing enter.

$32 should be 1 (enable laser mode)

$30 should be 1000

The $30 value can be set either in your firmware to match LightBurn, or in the LightBurn device settings (S Max) to match your GRBL setting.


(andrew manus) #8

This is what I found out I can put Text or a Shape in the Drawing area Then Save it under G code then
bring the Code up in Note pad then Change the M4 to M3 and save the program. And my Laser burns the Program Great So How do I get Lightburn to Change M4 to M3

Thanks Andrew


(Rick James) #9

@amanus, we still don’t know what firmware and firmware version you are using. Is there a reason you are not sharing this information?


(andrew manus) #10

GRBL Version 1.1f.20170801:OPT:V,15,128. Sorry I just assumed you had the same problem from other users

Andrew Manus


(Oz) #12

If you want to use M3, you can do so by clicking “Devices”, then creating a new device using GRBL-M3 instead of just “GRBL”. Delete the old device so none of the old settings pollute the new device.

When Rick asks questions about what device you have and what your settings are, it’s because LightBurn supports so many different lasers that in order to give correct advice, we have to know what your device is and what the settings are. Without knowing that, there’s no way for us to know if other users have had the same issue.

And Rick did give you the correct solution for your issue, if you want to continue using the M4 device, here:

If you’d prefer to switch to using M3, follow the steps I wrote above.


(andrew manus) #13

There are No choices Listed Under New Devices, Should I Reinstall lightburn


(andrew manus) #14

I chose the GRBL m3 an it worked. So As Guess I went back to GRBL 1.1f and Now everything is working properly All lines and Shapes are closed the laser will fire I can set the Variable Power. I really like the Lightburn software and will Purchase it. Thank you Rick an Oz, Sorry I was so Vague.

Andrew Manus


(Rick James) #15

Glad you are all sorted. :slight_smile: