Force laser Mode

Hello Everyone. Is it possible to force Laser Mode always on?

I have a cheap Chinese Laser.

I know that I can set $32=1 in the console.
I set a macro to make it happen more easily.

But I seem to need to set it after every cut. Also I just had an instance where set it 3 times. The logs even show it with the ‘ok’ but when the cut actually started it was apparently off. (I stopped the cut and rechecked with $$)

Can this be done automatically or forced in the device firmware? Thanks

Recently got a Vigotec VG-L7 engraving machine. Thought to check connection before downloading their software/firmware and it appeared to have generic Grbl 1.1f on the laser controller board… which I was ecstatic about (didn’t want their proprietary stuff). Anyway, after using it for a while noticed the same thing… after every connection reset, the $32=1 setting I wanted was set back to 0. Finally decided to try reflashing with Grbl 1.1h that I use on all my other machines and was successful. Now my settings are retained between jobs/resets. It’s now a nice generic little Grbl machine.


Oh thanks for your response. I’ll look up the firmware and try to update and post my results.

The settings are stored in flash memory on the controller, and flash memory has a limited number of times it can be written to (about 10,000). If we were to set it constantly, at the beginning of every job, it wouldn’t take too long before we’d break the controller for good. Some companies ship their controllers with the firmware modified to enforce certain settings that they want for their stock software.

This did in fact work for me. Thank you!

I didn’t know it was writing it to flash every time. that really would be bad then. Updating the firmware solved my problem,

hi David, I’m not very experienced. i have recently discovered lightburn software and wish i could use them with my new vigotec vgl7 laser. unfortunately he can’t find it for me. what do I have to do for it to work. hope you can help me, mother software sucks. thank you so much. a smile, Roberto

You should probably start a new thread with your question. I doubt anybody would check this post again since I said that the problem was solved.

perhaps you can check this forum post. according to this forum post the engraver is GRBL compatable but that’s as far as I can help with my current level of knowledge.

I’m sorry, Roberto. I don’t use Lightburn to actually control my machines… but only to create gcode files. I use CNC.js over wifi, running on a Pi-3B+, and Grbl 1.1h to actually control my machines.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.