Frame not framed?

I have another issue I’m running into with my Creality Ender 3s1 and 5w laser. I have Lightburn configured for Marlin. I import a file, either SVG or DXF, doesn’t matter, and I have two layers. 1 is the image. I have it set for fill and the setting “Fill all shapes at once”. The second layer is T1, Frame, the size of the object I’m printing on and the graphic lined up properly in the middle of it for centering. I run the Frame command and everything looks correct, the laser head runs the perimeter correctly and everything is on the wood, but when it starts printing, things appear to have shifted left and it’s printing the item off of the wood. I haven’t changed any settings that I’m aware of in the software. What could cause that?

Can you take a full screenshot of LightBurn with the design loaded as if ready to burn? Please have the Cut and Laser windows showing in the screenshot.

Okay, update. I uninstalled and reinstalled the software out of frustration. When I set it back up, instead of it selecting Marlin, it went with GRBL-M3. So I’m going to play with that for a bit, but so far, it’s at least printing in the ball park.

I’d guess it’s a current position setting under laser. Try absolute controls or user position.

ETA: Probably not the solution, I think Frame vs cutting should be the same location in that scenario.

If you have a Marlin device you really want to go with Marlin… or rather you may not have a choice if you want proper control. GRBL-M3 is considered the most basic of the g-code profiles, however, so some of it may work.

I realize that the Ender 3s1 is not a laser engraver. And the more I work with it to try to make it one, the more walls I keep slamming into. I think I just need to break down and buy a big boy machine lol

And with GRBL-M3 on the Ender, laser is ALWAYS at 100%.

Many come to the same conclusion. Note that there are Marlin branches that are better tuned for laser functionality. There have been some discussed on this forum.

Not sure what controller you have but one user was able to use Klipper satisfactorily once a few issues were addressed.

It’s possible that there may be a GRBL firmware compiled for your controller as well if that’s an option.

Yeah, I was worried that this might be one of the issues, although that may be fixable.

1 Like

Well, in my tests so far (of course I have to go to bed, 5:00 am alarm doesn’t care about lasering), it appears removing the software, reinstalling and configuring for Marlin again has solved this and the other problem that I was having yesterday. I must have clicked something somewhere and didn’t realize it. THANK YOU for all the help!!!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.