Frame Slop Error frustration

I am continuously frustrated with “Frame Slop”. I’ve posted and received good advice on here and other places before, but I am still struggling to understand.

I have a Ruida controlled Boss Laser LS-1420.

I’m trying to cut a stencil out of a piece of acrylic. I created a rectangle the size of the overall sheet, and then centered the text in the middle of that rectangle. I then realized that at the overall width of the text I wanted, it was too large to cut in one job for my laser bed (needs to be 21" wide, I have 20" of bed on that axis).

So, in order to preserve the origin at the center of my acrylic sheet, I made two of the letters a different layer and then turned the output for that layer off (I also turned the output off for the rectangle). The cut speed is 5mm/s, so I don’t think that is the problem. As soon as I try to start the job I get the beeps and the “frame slop error”. I can’t for the life of me figure out why, as I’ve moved everything inward (I was originally only going to have one letter on the second job, but I made it two just to give it more space and try to solve the problem). There should be PLENTY of space around the letters, especially cutting and at 5mm/s.

My only theory is that the software/controller is seeing the too-big layers as part of the job, and telling me it can’t cut them even though their output is set to off. My problem is that if I delete the two letters outright, it shifts the origin over and I’m no longer centered on the acrylic sheet/no longer have a way to really accurately measure what that shift is.

Two screenshots attached, am I missing something?

EDIT: I did the following and STILL got the frame slop error: I deleted the rectangle and “NG” in “DIVING” outright. I noted a 31.5mm shift in the origin to the left, so I just moved the head over that amount with the Lightburn controls. I hit start and got the same frame slop error… how is that possible with everything so well inside the edges of my bed, on a “line” job? I searched for any errant shapes that were elsewhere on the workspace in Lightburn but couldn’t locate any.

The frame and orange lettering, even though you aren’t sending them to the laser, are being considered for framing and sizing. The controller is telling you that part of the job might be out of the cutting area, but you should be able to just hit Enter on the controller and it will do whatever part it can that is still within the bounds (in your case, all the cuts should be).

1 Like

Thanks for the quick reply. I’m confused why I’m still receiving the error even if I do delete the frame and extra lettering?

You’re running the job from “Current Position” mode, so the bounds checking would happen based on the location of the laser head and the size of the job - it wouldn’t have anything to do with the positions of things in the software. Where was the laser head when you went to start the job? (IE, what coordinate?) and how big is the text you were running?

As an example, assume the laser was at 200x, and the text is 450mm wide. If you run the job from “current position” with a center origin, that means that half the job goes to either side of that “200x” value. The job is 450mm wide, so half of that is 225mm. That means it would go to 200x + 225 on the left side (425x) and 200x - 225 on the right (-25x). -25x is out of bounds.

1 Like

I used to get frustrated by this now and then. You have to pay close attention to exactly where the current position is set verses overall size of your artwork as well as where the origin or starting point is set.
Assuming you have it set to center starting point you have to be sure the laser head is in the dead center of your machine if you want to get the most available room when running files that are close to the max bed size.
You can engrave or cut pretty close to the full bed size but not completely you have to have, and I am guessing here, about 5mm or so loss for the head to overscan and not hit the end. Again it seems about that much to me.
Be sure if you are using center start point your head is in the center…not close to it but dead center. Look at the X,Y coordinates on the Ruida and move it to it. Assuming it is a 300x500 then obviously be sure you are at 150/250 when you start and you can easily make this.
This is why, somewhere it is said, it is easier to avoid frame slop errors by using your origin and starting point from say the front left corner…could be rear as well but you get less frame slop errors if the artwork is within the limits of the frame and the physical starting origin and starting point ( green box ) is in a corner of the machine .
Most all frame slop errors that come up with artwork that is within the actual frame are due to a conflict with where the absolute position of the head is relative to the starting point.
Also as said be sure if you have multiple designs, even if one is not set to output, that one is not offset because even if it is set to not output it will move the little green box that indicates the starting origin…that has boned me more than once. Ghost artwork, as I call it, is a layer that I have turned off both show and output however it is still used in calculating the overall start point indicated by the little green box seen in your design…and hidden layers can skew that point especially if you move any layer around.
In your first pic you have a ghost design not set to output but…it will be used to calculate where the center is if set to center origin…the little green box
Pay close attention to the little green box…make sure if set to center it is in the actual center of the art…a little skewed will cause frame slop errors in large artwork as now the center is not where you think. This is only an issue if you have several separate designs (layers) in the palette and one is offset even if output is off. For a single layer design then this can’t happen. SO be careful moving a layer around if there are other layers turned off.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.