Frame slop workaround

In common with many people here, I have had problems with frame slop errors. Even after deleting the frame, shutting down the laser and also the Ruida software, the system still manages to somehow remember the frame that has been deleted.

My solution/workaround, is to change the frame to a circle with a diameter of 0.1mm and put this in the top corner at a distance of 0.05mm for both X and Y. And Wooohoo - it worked.

Not sure you understand what a ‘frame slop error is’.

It has nothing to do with any frame object, retangular or circular.

It’s telling you that your job will not allow the laser head to remain within the bounds of your machine at the speed you have selected.

Actually, I think that I did understand. My point was, that although I had completely removed the errant frame I had previously drawn around the whole box, the Ruida laser machine controller refused to believe that the frame was no longer there and so still refused to work.
Although I didn’t try it, possibly resizing and then centering the frame to a millimetre less in X and Y would have also resolved the problem.

A frame slop error indicates that at the speed you have selected, the machine can’t decelerate, move and accelerate back to speed, within the bounds of the gantry and would ‘crash’ if it attempted it.

Making the object smaller can bring the potential motion within those limits, as can changing the speed. A more aggressive acceleration/deceleration profile can reduce your frame slop margin, markedly.

If you have good tolerances, a good drive system, adequate DC power, decent drivers and steppers, you can get a lot out of tuning your profile.

Reducing mass and friction are obvious places to start when dealing with accelerating objects.

Thanks for that Bo
The problem that I had was that I had drawn a frame all around the perimeter, from X0,Y0 to X500,Y300, (I use this frame for positioning/repositioning items on the screen) so the machine was having problems with that frame. However, even after deleting the frame, turning off the power and back on again, it would still not work but continued to give me a frame slop error warning. But, when I drew a small circle in the corner (using the same colour and speeds etc), it seemed to accept this as a new instruction and decided that this would be OK for it to do.
So, I am just saying that it worked after giving me a frame slop error.