From Fusion to Lightburn - DXF

Friends, I am searching for a workaround as I am sure this is a Fusion’s exporter issue and not Lightburn fault. For those designing sketches in Fusion360 and exporting those to lightburn: more and more I find myself projecting 3D geometry into 2D sketches for laser cutting a 3D models instead of 3D printing those. I am having some hard time cleaning files because fusion creates arcs from projected geometry and their corresponding spline’s control points, which are construction lines in fusion, are exported as part of the DXF file as well. Lightburn import those as well and that, so i think, messes things up.


Fusion:


Lightburn having hard time distinguishing between fusion splines and construction lines.
fusion construction lines confuses lightburn and i can’t dash the lines. the slots comes out OK since they do not have construction lines.

F2LB-DXF.lbrn (49.1 KB)

F-DXF-EXPORT.txt (24.0 KB) (Change from .txt to .dxf)

I looked at your DXF file in a text editor, and the entities you want to remove are defined as:

LINE
ARC
SPLINE

The entities defined as LWPOLYLINE are what you want in Lightburn. I can easily delete the unwanted entities in NanoCAD v5 or Draftsight.

Here is a video that creates a new sketch in Fusion 360 that might work for you.

I would extrude the sketch, create a 2d drawing of the model and export this as a dxf.

Hi Ralph,
I am not familiar with these CAD software you use. are you saying they differentiate between splines and construction lines in the dxf file exported from fusion? i can of course make a copy of these sketches and delete the construction lines within fusion before exporting but I am trying to avoid this step.

Have you tried / succeeded / failed / to dash my dxf shape’s outer spline within Lightburn?

Hi Jeremy,
Few month back I would have done this but Autodesk changed the permissions and features available for personal use license and exporting drawing is not available anymore. you can create drawings but not export these out of Fusion.

Cheers.

In the DXF file you provided, the entities that you are referring to as “construction lines” are defined as:
LINE
ARC
SPLINE
image

Not sure what you mean by this. When I look at all of the entities in the DXF file in Draftsight and NanoCAD, none of the lines contain dashes. I could delete the extraneous lines in LB, but much harder. It was easier to delete them in LB after I looked at the file in CAD. I am somewhat familiar with Fusion 360, but I usually import DXF files, then create extrusions from the imported sketches.

In Fusion 360, I extrude the model from the sketch, even if only a few mm, turn off all the sketches, and then hit P for project. Click on the centre of the model which will project all the outline. If you don’t want certain lines, then you need to click them individually to remove them from the projection. Then save the projection. End the sketch. Right click the new sketch and save as DXF. That always works for me.
This function works with the personal use licence.
Cheers

David

Hello David, This is how I go about it.
I made few tests and found out that there is a difference between projecting the whole body and projecting specific entities. when i project the entire body - all looks to be ok. when i select view and select all entities - Fusion generates construction lines for arcs and include those in the dxf exporter and that messes things up. interesting finding. I will dig deeper to understand why is that so.

Interesting, I can’t reproduce that behaviour at all. What ever I do I don’t get construction lines or additional nodes selected with the dxf. I even added lines to my model, and added a circle sketch and extruded through the model and still I only get the outline and the extruded circle perimeter. I even tried turning on visibility for all sketches before projecting and still no extras!. It will be interesting to see what you find out.

Cheers

David

My theory is that since the model i am projecting is partially a mesh (stl) converted to BRep, the “project specific entities” catches the mesh tessellations which primitive / parametric bodies has not.

That is super annoying !

Projecting the entire body and not specific entities did the trick.
Now when i import the dxf to lightrun the lines and splines are dashed as expected.

ice_screenshot_20210313-072519

Cheers.

Yes, starting with an STL would likely cause the problem. Glad you got it sorted.

Cheers

David

The thing is the base which is being projected is not part of the stl but added by me to the BRep during remix then I’ve added these fillets and bolts slots. My guess is that fusion deals with BRep differently than with pure primitive bodies. No biggie.

I use an add-on with Fusion called DXF for laser. I have found it works really well creating the dxf.
https://apps.autodesk.com/FUSION/en/Detail/Index?id=7634902334100976871&os=Win64&appLang=en

Thanks Philip, do you know what this does differently than the methods described above?

Cheers

David

Thanks Philip. I don’t think this plug is for windows as well. checking.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.