G-Code Motion Target Exceeded GRBL Win 10 / Lightburn

What is causing this?
Grbl 1.1f [‘$’ for help]
[MSG:‘$H’|‘$X’ to unlock]
[MSG:Caution: Unlocked]
Waiting for connection…
Target buffer size found
Starting stream
G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the ‘Devices’ button to reset the connection)
On or near line 2:
Stream completed in 0:00
[MSG:Reset to continue]
Grbl 1.1f [‘$’ for help]
[MSG:‘$H’|‘$X’ to unlock]
[MSG:Caution: Unlocked]

This means you’re asking the machine to run something that will put it past the machine’s understanding of its boundaries.

If you’re not already, I’d suggest you use Absolute Coords as your start from mode in Laser window. Also, make sure you never move the laser module by hand after it’s been homed. Use jogging controls in Move window or on the machine exclusively. Movement done by hand is not tracked by the machine and it will not have awareness of its actual position.

I have the machine set for X-365mm and Y-395mm this is from the manual and called working area, the motion area is 400 x400mm.
My one problem is do I have the proper firmware installed as I have no idea how to look for GRBL Firmware.

How have you done this? Can you take a screenshot of the manual showing this?

It’s definitely GRBL as indicated in the Console output. It shows Grbl 1.1f.

here is the manual specs and
here is the manual.
I also had this popup doing an interval test and the laser worked for a bit beforeit stopped.

Interval Test2023-06-05 160015

Console interval test2023-06-05 160105
And I can tell when things are going to go haywire as windowswill beep me, Here is a video of what it does

Is this indicating negative numbers? Or are you saying X is 365mm and Y is 395mm? If the latter that’s fine. I thought you were saying that these were meant to be negative coordinates. One note is that you may want to confirm that 365mm is meant to be on the X rather than the Y. It’s ambiguous how it’s listed in the specs so it could be the other way.

One thing I didn’t realize is that your machine homes to the lower-right. That’s quite unusual.

Can you do “Get Position” in Move window at every corner and record what those coordinates for each corner and report back?

Also note that I wasn’t able to check the video that you posted. Seems to require login.

Today I tried again even wiped my HD well wiped as far as windows lets me and here is what i found;
Power switch was faulty when I pushed the repeat button and the power the light in the switch would flicker some times stay on but mostly off , so I removed the boaed and found a broken terminal on the switch and after a bit of putzing I soldered the power wire to the switch. Next item was when the power was on sometimes the gantry would go into nuetral but the laser lockedup well if I played with the power switch I could get the motors to hold in position and home. Time to do a simple burn and it worked was going right along then the dreaded bong and it stopped, the motors had lost power but the Laser still had power. I am sorry to say I should never have purchaesd this thing and did more research.I will keep this and see if I can put a arduino on it instead of this special board. Anyway I met a bunch of good people and that is worth a lot so
God Bless
and say a prayer for Ukraine.

1 Like

I called Sainsmart and now they think the problem is the power supply, now I will admit it had crossed my mind so I reached over and grabbed it and I let go like fast it was hot and the plastic was a bit soft there is no idea when they can ship a newer supply out. Not wanting to wait I ordered a new Atomstack S10 Pro and it works.

I am so happy.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.