G Weike LC1390 machine setup in lightburn

Hi, I have G Weike LC1390 laser cutter, it is about ten years old. is there a way to connect my laptop via USB to the machine? When I select Trocen i can see the status ready but i can not do anything. Is there any issue with drivers or? thanks for help. Jiri

Hi Jiri - what software came with the machine? I would expect G Weike would be Ruida based, not Trocen. Have you tried the “Find my Laser” button in the latest release?

Actually, many G Weicke machines shipped with Leetro controllers, mine for example came with a Leetro 6515 which I changed out to a Ruida to use LightBurn. They only ship Ruida if you specify it when ordering.

This page might help you ID the controller:

1 Like

Software that came with the machine was laser cut 5.1.
I have latest release of LB (0.9) and find my laser shows empty window. Nothing to select except go back… When i tried to add machine manually Ruida was not responding at all. I tried Trocen and in the laser window (in LB) it changed to ready. but even it is not connected now, LB still says ready.

USB i try to use is going to the 6515 board. I took some pictures as i am no longer in my workshop.

Ah, so lasercut means you have a Leetro controller. These are not yet supported in LightBurn. You would have to replace the controller if you wanted to use LightBurn with it now.


Well. I took closer look and yes. it is Leetro. So the only option is to wait or change to Ruida controller. Thanks for hints!

1 Like