G0 Setting between cuts

Trying to set the G0 setting higher between cuts to speed up the burn process, have tried several different settings but no luck yet!

Have a look at the ‘Fast Whitespace Scan’ option in the ‘Device Settings’ window.image



OK, set this at 9999, G0 whitespace still moves at same speed as laser, tried adjusting the speed in grbl, didn’t make any difference, still trying. Using DIY laser with Keysstudio latest
controller, everything works fine except the whitespace movement?

Trying to move it 33 feet per second probably isn’t doing you any good.

1 Like

Changed all speeds to 500, no change, laser and whitespace still the same?

In GRBL itself, there are settings for Max Rate on each axis - X is $110, Y is $111. These rates are set in mm/minute, so ‘500’ would be quite slow.

The Fast Whitespace Scan Rick pointed out is only for traversal moves within a raster engraving, not moving between shapes or cuts. That speed is the Max Rate setting in the controller itself that I noted above. You can set them in the console window, or in the Machine Settings window in LightBurn.

The speed value is one of two things that will affect the traversal rate, with the other value being acceleration ($120 and $121). If the acceleration is low, it will take a while to get up to whatever speed you ask for, so that could be part of the issue as well.

1 Like

That board is based on an ATMega 328, likely running at 16MHz, which means it has a maximum step rate of about 30khz. Depending on your steps per mm settings, you could be hitting that upper limit as well.

For example, if your motor drivers and gearing mean you need 300 steps per mm, you would never be able to faster than 100mm/sec, as that would be 30,000 motor steps per second. Without more info about the machine itself it’s hard to offer much more than that.

Thanks to all for your help! I’ll experiment with your suggestions today.

Laser is working fine now. Is there no way to set different speeds for the burn and move cycle. I have adjusted the speed and acceleration several times, still get my moves and
burns at the same speed.

Can you post what the controller responds with when you type $$ in the console? GRBL treats G0 and G1 moves differently, and G0 should be going at the max rate specified in the controller settings, so unless you have it set really low, this makes no sense.

I’m suspecting that your max rate is too low, and you’re trying to run normal jobs with the speed above that, so everything moves at the max speed. It happens often.

This my current grbl settings, thanx

There’s your problem. You have your X & Y maximum speeds set to 500mm/minute, which is about 8.3mm/sec.

Your acceleration rates are also a bit low, and you’re not in laser mode ($32 should be 1).

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.