Galvo Issues - beam firing during framing

My company wants me to resurrect this galvo.
Seems worthwhile since it’s a 30W Raycus.

It came with that board, and a computer (running what appears to be a janky cracked version of win 7 throwing HDD issues that was included with the fiber) preinstalled with EZCAD 2.7.6 and is “functional” within the context of EZCAD, when the OS isn’t crapping out.

Since the PC is on its last legs I figured time to upgrade PC’s too.
The supplied drivers installed on Win 11, but the dongle driver failed.

Figured I’d try LB and see if I could get it to do anything.
Driver swap worked, but LB never saw the COM port attached to the board in the devices list and would never detect the controller attached.

Upgraded to a new board JCZ Lite.

Driver install worked fine, (although can’t use EZCAD). LB driver update was fine, and scans and detects the hardware dandy.

But now the frame command is firing the laser itself.

Any idea how to resolve?

Here’s what the device settings look like.

Might try changing the type to IGP_YLP. I read somewhere that corrected many problems… They mentioned the board being a cyclone type board…

I don’t think it could hurt anything to try it and see if it’s works better…

I’ve never changed this around as mine seems to work…

Sorry I can’t find the thread…

Good luck



Disregard the above… I misunderstood how that frame dialog box worked. XD

My issue NOW is just "no red dot during “frame.” The laser isn’t firing when it’s not supposed.

So the board swap is a partial success…

Now I just need to get the frame function working properly with this board…
OMTech JCZ Ezcad2 Fiber Laser Controller for IPG Raycus MAX Fiber Laser Marker 797434254498 | eBay

I’m guessing it’s some combination of these settings over in the red dot area, but I have NO idea which ones are what.

Probably here…