Galvo rotary banding/striping issues

I’m having trouble with rotary on a galvo where i’m getting this striping pattern. my split size and lines/mm are both set to .02mm. Does anyone have experience with this?
Thank you

Chuck or roller? Diameter of workpiece? If Chuck, what are your steps set for in LB? Does the rotary turn 360 when you hit test? Post screenshots of your parameters and rotary setup.
It looks like cadence, and 0.02/ 0.02 is probably causing a lot of that. If you answer the questions above probably can get you straightened out easily enough. .

thank you for the response!

-tumbler is 80mm
-steps 12800

What do you think?

If tumbler exactly 80mm,

Circumference Steps resolution
251.3274123 12800 0.01963495408

So the surface moves 0.0196mm with each step. Your 0.02 is pretty close, The small difference is possibly what is causing the cadence pattern. I would suggest a multiple of 0.0196 for your split like 30 or 40. 30 hits a zero 3 places in so example split 0.589mm, line interval 0.0196

resolution Multiple D*E
0.03926990817 2.000000
0.07853981634 4.000000
0.1963495408 10.000000
0.7853981634 40.000000
0.5890486225 30.000000
0.07853981634 4.000000
0.09817477042 5.000000

and your line interval equally divided into that
0.0196 is pretty close to your desired 0.02mm
Adjust as necessary if your tumbler is not exactly 80mm at largest point of engraving,
circumference divided by steps = resolution

I get some pretty nice engravings with the rotary using this math, but admit I do more marking and engraving then I do removing powdercoat. That has a lot of other factors you will need to work through.

1 Like

An exact multiple of 0.0196 does not help. I saw another thread where you posted this solution but unfortunately i have a different issue. Could jump settings be a problem? (saw that in a different thread)

Did you dial in your timing and jump per the laser everything video?

I did, but I’m not certain it came out right because Lightburn doesn’t have that “average distribute line” setting so I wasn’t able to obtain the same hatch that he has in the video. I had to manually draw the shape with lines and not use hatch. It looks the same but , for example, the laser off TC gaps in my test werent anything near what he had in the video. Im going to go through it again to make sure everything is good.

You have to use 2 sublayers, draw the border as a line on second layer or just draw the whole thing like you did.

Seems like there is a setting that centers the hatch but don’t remember and not near laser.

Recalibrated all the TC and put the jump settings to the safe slow settings. Nothing has changed. Tried to do some 3mm squares filled with .025 interval and all different slices divisible by .0195.
I can hear the laser stuttering/pausing/skipping steps a couple of times during the test. You’d think a solid 3mm square would fill consistently and evenly, and it does when Im not using rotary. I have tried two different computers with the same result. Any ideas?

You are scanning parallel to the rotation axis, correct?
Rotary operations are handled differently then flat, “how” is above my paygrade, but one thing I did was build a belt drive 6:1 and run it at 6400 steps so resulting ratio is 38400 steps for 360 degrees, runs pretty smooth. I still calculate my steps and line interval though…
The other thing is coated tumblers are always a challenge with fiber, try a cup uncoated similar size low power and see what happens.

Yes parallel to the axis of rotation. Here is 100x100 square on the bare bottom part of this cup. Same pattern.

Really looks like a cadence from the rotary moving unevenly or incorrect diameter. Are you still using the parameters you show above?
Only simple thing left is change DIP 4 to full amperage, maybe up the overall amperage.

Yes still same settings. Wondering if the rotary or board is faulty. where is dip switch 4, on the control board? I haven’t had this thing open yet.

So your slices divide into the circumference but does your line interval divide into the slice?
DIP 4 is on the microstep driver


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.