GCode scale issue

Hello,

I’m trying to draw some shapes, like a square and saving as GCode.
When I preview the path, there is a scale error. X is OK. But Y is around 2x too big… I tried to reset all settings, even uninstall, downgrade version… but nothing would fix it…

Example for a square :

; LightBurn 1.1.04
; GRBL-M3 (1.1e or earlier) device profile, absolute coords
; Bounds: X0 Y0 to X10 Y10
G00 G17 G40 G21 G54
G90
; Cut @ 300 mm/sec, 100% power
M8
M5
G0 X0Y0
; Layer C00
M3
G1 Y22.918S1000F18000
G1 X10
G1 Y0
G1 X0
M5
M9
G1 S0
G90
; return to user-defined finish pos
G0 X0 Y0
M2

Has anyone already had this issue at some point ?

Any help/advice would be appreciated. Regards,

Looks like your rotary is enabled. Disable that and retry.

Also, is there a reason why you’ve setup a GRBL-M3 device? Typically would be better to use GRBL if you’re able.

1 Like

Awesome, that was because of the rotary. I tried it some times ago but I thought it would disable it by resetting all settings and/or re-installing the software. Thanks so much for the tip
Aso I’ve setup a GRBL-M3 to try to drive a EleksMaker.
I also have a K40.
I’m not sure to really understand the diff between GRBL and GRBL-M3
image

Glad that worked.

GRBL-M3 is meant literally for controllers using older version of GRBL (1.1e or earlier). This is before GRBL got laser mode and variable power.

Eleksmaker could fit this if you’re using the original firmware on your controller.

Can you run this command in Console? If it returns 1.1e or less then GRBL-M3 is appropriate or you could choose to upgrade your firmware. If it’s 1.1f or newer then you could use standard GRBL and get the benefit of laser mode and variable power.

$I