Genmitsu L8 laser engraver fails to connect to Lightburn

Dear Support

I wonder whether you can help me. I have purchased a new Genmitsu L8 laser. I can’t get it to connect to my computer or laptop that have Lightburn installed. They previously worked with Sculfun S9.

I have installed the CH340 driver, switched on and off, changed the cables. I would like to add another COM port. I currently only have COM1 on my computer that had been used to run the Sculfun.

It’s a brand new laser but now I’m wondering whether it’s faulty or maybe there is something that I need to do.

I would be very grateful for your help.

Com 1 is typically an internal motherboard serial.
I would think your CH340 drivers did not install correctly.

Can you right click the window’s menu > Device manager?
Expand it and see if any device appears and disappears when you plug and unplug USB cable?

3 Likes

OK, I will give it a try.

I tried it.
Nothing happens.
The Device manager reacted when I plugged my smartphone in and out.

The laser is not recognized.
I notice that CH340 is not displayed as a COM in the Port section. It installs but doesn’t register on my Windows 10 computer or laptop.

Thanks for your help.
I’m wondering if there’s something wrong with my new laser.

Without the driver should my computer still recognize the laser when it’s plugged into the USB port?