Get Position totally off my workspace! HELP!

My neje 2S max is totally going nuts.
I have been using the laser for a month and everything was perfect, but today, the day i bought the licenses, between some cuts, something happen…

Feels like the machine is drunk.
Let me explain you.
When i click home, it goes to top left corner of the workspace (good) but if i check my position place it shows x810.00 Y 920 (my working size it’s set to width 810 height 460 on the device settings)
How can i fix it?
i tried to move manually my laser to the right bottom corner and move it with the arrows so i can bring it to x0 y0, but after that i click on set origin, it goes back to the x810 y920.
I have been fighting for hours and no idea what to do.


Type $# in the console and press enter - what does it say in response?

Then type ? and press enter. What does that say?

EEPROM read failed. Reset and restored to default values.

then i click also $$ and that’s what it shows:


You have a workspace offset enabled. Did you use LaserGRBL or some other software and ‘Set origin’ in it? You can clear that by typing this in the console:

G10 L2 P1 X0 Y0 (enter)

i did not use any other software. everything changed meanwhile the lightburn was open, between cut and cut

LightBurn never issues commands that will change this (you have to do this either through the console, or a macro). The only way this could happen is if you homed the machine and the home location was strange, like rear-right instead of front-left.

I believe he did notice, since he included it:

It’s fixed guys.
I went in to machine settings and started to try some things and it worked. I don’t know what it was, but it worked.


Had you tried Oz’s suggestion? Random changes would not have fixed this.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.