Graphics need to be smashed on screen to burn correctly

When I am seeing things on screen, it looks very differently from what burns on the laser.

Particularly, I need to “smash down” graphics (shorten Y axis) for them to look right when they burn.

X axis is working correctly.

Am I doing something wrong?

I think your y-axis is not right calibrated, so that 1cm is not 1cm

Thanks! I am a ripe newbie at this, and I merely added the laser.

What is the right way to calibrate it?

Also… why would X get picked up correctly, but not Y? Just curious…

Don’t know what laser you use(which brand) but in GRBL(arduino) you can tell how many pulses is 1 cm. Calibrating is telling the number of steps per cm.

Ortur LaserMaster 2

Looks like the Ortur LaserMaster 2 is GRBL based from what I could quickly find. Like @Har4har says, you can configure the number of steps per millimeter to be taken by the laser. Look at your configuration through LaserGRBL ( and pay special attention to settings $100 and $101 (X and Y steps per mm respectively).

If they’re set to different values, but your laser uses the same drive ratio and microstepping settings for both axes, there’s your problem. If one of the axes is actually accurate, set the other axis to the correct axis’ value and you should be good. In both axes are off, set both to a convenient (round) testing value and cut a square to measure and calibrate.

Have you turned on the Rotary setting, by chance? That would affect the Y axis scaling. (Edit > Rotary settings, then make sure the Enable switch is off / red)

1 Like

Oz, you are spot on!

I had the rotary switch enabled by mistake.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.