Gravity and vertical axis

I use an eleksmaker mountrd on a wall. it works fine as long as code is streamimng.
But when the program has finished the carriage on the vertical axis fall down due to gravity whis I would like it to stay at the last coordinates.
Jogging the vertical axis is also impossible. The jog command is executed and the it falls down.
I guess the stepper drive is disabled when the command finish.
Does anyone know a way to prevent it?


There is setting in the GRBL that can do this for you. Step idle delay($1) Setting it to 255 keeps grbl from idling the steppers. The default is often 25. Downside they can get hot. I have mine set to 255 and it has never caused me a problem. If you type $$ in the console window you will see the current value. If you want to change it type $1=255. Into the command box and hit enter.

Hope that helps,


Sounds just what I’m looking for. Will it remain like this until I change it or reset the controller?
Can I insert these commands in the g-code?

You don’t need to insert the commands - type it once in the console and it will set it in the firmware, and as long as the Eleksmaker firmware isn’t resetting it, it will stay.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.