GRBL 1.1F axis issue

I solved problem that at beggining I couldn’t set proper homing- homing was Z top, X left, Y forward, and after that when I was commanding by “move laser” it was always trying to go even more forward in Y axis. Now I have one more issue. I changed homing to Y back side, and its working correctly for clicking laser by mouse, but if I try to move it by JOG I can move correctly Z, X, but Y only backward. If I click forward its trying to override whole machine.

Any idea how to solve it? I have problem only in LB

I’ve just tried to follow again You “how to connect 3018” and results are:
I’m following the sequence:

  1. Homing
  2. G92x0y0z0
  3. Trying if axis are responding correctly for jog
  4. Trying to use “move laser” opt in software.
  5. Trying to cut anything.

When I was using LaserGRBL there was no such problems, here the software cannot set proper way +/-. After some tests I noticed it doesn’t matter what I would set. Its randomly homing Y axis forward, or backward and same with movements - once positions on screen are same for machine, once they are invert. What I mean? Imagine rectangle which U can see on Your laptop- its Your worktable. You have scale on right from 0 to 140. When You are using Your machine you have only two options- 1) when You re clicking on screen to move laser, its working correctly, but then cutting process is invert 2) moving laser option is invert, but then Your cutting proces is able to work.
I tried it rn about 4rth day to solve those problems and what I can say- program have all necessary options, but with this gRbL it can’t work.

ALARM:1 is a hard limit triggered. With GRBL, the origin is usually front-left, with +X going right, and +Y going toward the back of the machine.

Your two pictures show different ‘Start From’ settings, and you might not understand how those work, so I would say start here:

Check to make sure $10=0 as well. If that isn’t set, the machine will be reporting its position in the wrong space, and that will confuse the software.

I exactly know that is hard limit. What I was trying to show, that doesn’t matter what origin I’ll set, the machine won’t move properly. I’ve settled $10=0, and I was playing a lot with inverting XYZ to get proper results. When I had origin at front left, and every axis settled normally (without invert) after homing and setting all axis 0, anything what i was trying to do was out of my table.

I’m quite close to solve that problem but still not enough.

It’s quite likely that you had a work offset applied without having $10=0 set. That would fool LightBurn into thinking it was not in the correct position.

Finally i make it works. Still not perfect. X HOMING INVERT, y homing invert, then x moving invert and Y (was set to invert) set to normal. Then origin back right. Its working untill i will stop work during process. Then again I have to turn machine off and on, otherwise it would think again that table is. . Noone know where.
Ive setted 10=0 and did not set any offsets. I dont think that the issue is in my main board as Fusion and other cam programs works correctly. Whenever even I’m adding homing before process

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.