GRBL 1.1f problem

I just upgraded grbl to 1.1f from 1.1e on my Eleksmaker A3. It was working ok on earlier grbl but now the Y axis is reversed. I chose lower left when I selected the machine but in the move window if I press right arrow it goes right as it should but pressing the up arrow makes it come towards me. If I do $$ in console this is what I get.

$0=10 $1=25 $2=0 $3=0 $4=0 $5=0 $6=0 $10=1 $11=0.010 $12=0.002 $13=0 $20=0 $21=0 $22=0 $23=0 $24=100.000 $25=1000.000 $26=250 $27=1.000 $30=255 $31=0 $32=1 $100=80.000 $101=80.000 $102=80.000 $110=4000.000 $111=4000.000 $112=6000.000 $120=800.000 $121=800.000 $122=5000.000 $130=400.000 $131=300.000 $132=200.000 ok Assuming I need to change something here, how do I edit it please.

When you installed the new GRBL, you overwrote the settings. Short answer is you need to invert Y-axis by typing $3=2 in the console. See this page:–direction-port-invert-mask
In the future you should store the settings from $$ and change them back when installing. Note your $100 and $101 may also need changing if you find your laser doesn’t move the right distance any more or engravings are smaller/larger than they should be. Many of the other settings can cause problems like max acceleration, max speed, etc.

Brilliant thank you, sorry for late reply we went away for the weekend. Will get it sorted now :smile: Thanks again for your help.

How did you upgrade your GRBL

I just used T2 laser. I have bought the program (don’t like it) but you can update from the trial.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.