grbl . 1.1g or 1.1f ?

Should I be installing grbl 1.1f to work with lightburn & J-Tech laser ? I have 1.1g installed but cant get the laser to work ! I Have noticed that $31=1 & $32=0 in my existing grbl 1.1g ! or should I just change these to $31=1000 & $32=1 in 1.1g ? Also do I change this in ugs ? I am using Aspire & ugs for the CNC & it is working well I am a bit nervous about changing grbl settings ! I thought 1.1g was good for the laser as well.
Many thanks G

GRBL 1.1g will work fine. Set these:


Those settings are:

  • $30 max spindle RPM
  • $31 min spindle RPM
  • $32 laser mode

You can read about all the settings in GRBL and what they do here: Grbl v1.1 Configuration · gnea/grbl Wiki · GitHub

Thank you OZ Ive got it connected, grbl settings changed etc but it will not fire now ? I get a flash from it when I press the red button , but that’s it ? Really appreciate your help !!! Gordon Ps there are no lights on, on the laser controller & if I change the fan cable on the controller to the RHS I get a constant click & flash !

Some hi tech gear that’s suggested is a ‘vacuum’… :slight_smile:

Hi I still cant get laser to fire ! stepper motors etc work fine , but no laser or fan ! not even any green lights showing on laser control board , If I press the red reset button the fan & laser flash on for a millisecond but thats it ! if I change the smaller of the wires on the laser controller board & press the red reset button it wiil pulse off & on , changing the black & red cables in the back of the x-controller doesnt seem to make any difference ! from what I have been able to find online is the red cable from laser controller to the x-controller goes to the spindle(PWM) & the black cable to GND , 2 different videos 1 shows black going to the far right GND but an older video with laser mountings like mine show black going to 4th right GND ? dont suppose it matters but have tried them both with no difference Please help ! this is getting very frustrating !!!

I would suggest contacting either J-Tech or Inventables - The issue you’re having is either physical (wiring issue, etc) or configuration for that specific hardware. It’s likely something simple, but I don’t know either of these devices particularly well.

These are pretty simple with three connections.

Power is two of them and the PWM control line is the third.

You may have to post a photo of the wiring. As Oz suggested it would be wise to check with J-Tech.

Good luck :slight_smile:

I WAS going to give you a very strongly worded answer to that first post Jack Wilborn :face_with_symbols_over_mouth: :rofl: But I was hot & bothered at work trying to get this thing going today :stuck_out_tongue_closed_eyes: …But I have calmed doon a bit now & I will endevour to give things a wee hoover before posting a photo next time :wink: :rofl: Cheers for reading anyways ! I am thinking it must be a wiring thing as Im sure there was a problem setting up the X-carve cnc a year or so ago with having to change the wires in opposite ways to instructions .

Normally I don’t post like that, but… There was no intent to ‘excite’ you, just a pun on the mess. We are here to help and usually what I tell people first off is ‘sit down with a cup of coffee and relax’

I’ve broken more stuff getting frustrated and doing something I knew better…

It does sound like it should be an easy fix. Just check out what supposed to be and double check that it is. If you have varying descriptions, you may have to chase the wiring down to the part to ensure what’s what.

It is odd you don’t have a green light. If I remember that’s it saying it has power?

First shot should be what indicators do you have, and for us, we need to know what they are. A red led could be an error or normal operation.

Lot’s of people have these issues, we’ll get you up if you can be patient enough for us :slight_smile:

J-tech should be able to tell you what wires go where. It should be just power and pwm. I can see the PWM output of your board, so you should only need to ensure you have power.

It’s a two pronged fork, half hardware the other software. Ensure we have the proper hardware configuration before any worry about the software side. :slight_smile:

Yup cheers Jack ,don’t usually get annoyed easily ,just got a lot on my plate just now & this is just a wee hastle I could be doing without ! Not your fault there ! I am sure it is a wiring thing ,which for the life of me looks too easy to be the problem ,even changing them around doesnt seem to help any :thinking: Also although it is a new laser it was bought 4 years ago & circumstances ment I couldnt set it up back then . J-Tech have changed their instructions & I now need a password to access the older instruction :confounded: which I have never been given . Dont think this is a route I would reccommend to anyone , X-Carve,Aspire,UGS,J-Tech,lightburn too many cooks & no one seems to know what the other is doing !Although I am sure Everyone is great at their own part of it ! Have sent an email off to J-Tech so we will see what happens :crossed_fingers: for now I will just have to stay unexcited :joy: & spend my days vacuuming a workshop that should be producing :neutral_face:

We can probably figure this out, it’s not rocket science. If you want to try while you’re waiting for a reply from j-tech…

As I said there is only 3 connections. If you can follow them and confirm them, then we can start looking at the controller followed by lightburn… dubious it’s lightburn.

If I read your post correctly you have a 3.8 watt laser, input power, so it’s drawing about 320 ma. Do you have the power to run it? If it came this way, it’s probably ok, but it would be a drag to find out you don’t have enough power (wattage) to run it…:frowning:

If you value your hardware don’t ‘guess’ at these connections. Most of the time you can get away with it, but I guarantee you of being bitten. Follow the wires, your machine seems pretty open.

First ensure you have power to the device. Identify what the buttons and leds are supposed to do and how they are supposed to work. Most of these laser heads have a separate board that has the buttons and leds on it, I’m assuming that case here. Their purpose is usually manual control, which you seem to be lacking. I’ve seen simple to complex controllers that come with these lasers…

Once you figure out the laser head, we can move on to the controller… :slight_smile:

Any links to the hardware would be advantageous.

Keep in touch :slight_smile:

Thanks for that Jack
got a reply from Jay at J-Tech with a few things to try & yup I think your right :+1: it has nothing to do with lightburn or the X-carve , there appears to be some problem with the laser controller , the controller has a direct input from the 240v mains here in the UK & should fire up without any other connections. So we will see what he comes back with hopefully tomorrow ! Ill keep you posted when :crossed_fingers: I get it going !
Appreciate your help here Jack .Thanks

Great, I’m glad you found the issue. It’s always a bummer when you get a ‘new’ ‘bad’ part :frowning:

Take care… Let us know how it comes out… :slight_smile:

Jack I have been about round the twist trying to find something I had done wrong in the grbl settings or in lightburn or for that matter I was even blaming the X-carve & the idiot that built the thing …(namely ME Grin)
Anyways I cant fault Jay from J-Tech for quick response & customer service he thinks it must be a faulty power adapter after the test I did last night ! Really the thing that YOU had suggested :+1: …it certainly wouldnt be getting the power it needed if the B***** thing is faulty :face_with_raised_eyebrow: even worse it looks like there was just enough power coming through the thing to give everything a jolt ,just enough to make me think it couldnt be that !I just didnt expect anything new to be bad well not at that price ! Oh well :crossed_fingers: thats it Ill let you know if its running & thanks for trying to help there ! if nothing else I now have a cleaner workshop after your shaming :rofl:
Cheers again Gordon :+1:

As I said we’re here to help, not make you more P.O… Forget about the crack and enjoy your new toy when you get a ps…

These things only have a couple of weak spots and the led lasers don’t have a high voltage power supply to deal with like the CO2.

Take care, let us know how things go…


Cheers Jack
Just thought I would give a wee update … Jay from J-Tech sent out another plug last week :slightly_smiling_face: … plugged it in & hey presto it lit up & fans came on :grinning: … BUT… It will still not fire :confounded: could not get above 3.5v after typing G1 F100 M3 S1000 :cry: … changed wires over to output marked spndle (0-10V) & :slightly_smiling_face: power went up & seemed like it was going to get to 5v … :sob: can only get it up to 4.7v on 20% power …Lightburn stops at 20% … at 5% power Im getting 3.5v … at 20% Im getting 4.7V :man_shrugging: just cant get the 5v that Jay from J-Tech says I need !!! X-carve doesnt want to know & said they dont want anything to do with a laser / lightburn or J-Tech …Lightburn say its J-Tech , J-tech says its the X-controller & now X-Carve say they would recommend. that no one fits a laser to their machines …dispite inventables having a whole section in the forums dedicated to …LASERS :man_shrugging:
Im just waiting on a reply from Jay again gotta say he has been good at giving ideas but Im afraid it is about the end of the line now ! only thing he has suggested was to fit an opamp , buffer or a line driver :man_shrugging: … really didnt expect all this hastle…Im slowly loosing the will :neutral_face: … Oh I ment to say after typing the code in for full power & moving the cables to the (0-10v) outlet it does fire , just not in normal mode with the fire button , I am hoping there is something in the settings I could change :grimacing: Any ideas Jack ?

I don’t recommend connection to the ‘spindle’. This is the PWM output stage from the Woodpecker 3.2 grbl board.


You will notice the difference from where the laser connects compared to the spindle.

There is no difference between a ‘spindle’ and ‘laser’ as far as what’s happening. That grbl board should run it with no problem.

If I had to pick someone, I’d pick who I purchased the laser from. However, I’ll give you some ideas, maybe… I’m moving next week, so most of my stuff is packed up and I have one more thing to do my CO2 before I can pack it up, so I’m short on time…

The way to trouble shoot something is to follow the ‘signal’ from origin to destination. Where it goes in one but doesn’t come out identifies the problem.

The system here is pretty simple. You have a voltmeter so you can do basic testing.
See if your grbl is responding properly.

Without the laser connected does the PWM signal give you the proper output?

It should range from a low voltage up towards 5v as it’s ‘power’ is increased. The best was is with a scope, but your dvm will have to do. This is a digital signal, so you are reading some kind of rms value.

If that works, then it would appear that the control board is working.

To check the laser, put power to it and when you pull the PWM input high (+5v) it should fire a full power. Ensure everything is protected against the laser output.

If this works, it indicates both parts are working. Hopefully one of these tests will fail.

If both parts are working, then you have some kind of power issue between them. That’s when you start checking that there isn’t any voltage across the grounds of the power supply when they are NOT connected.

Good luck… Hopefully you will hit on it. I’ll be back, but not consistently until I get moved.
If nothing else, you’ll have a better understanding of how this stuff works… :slight_smile:

Take care


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.