GRBL 1.1v7 on UV XY laser not homing

I have tried a number of thing to resolve my homing issue, and now I have made it worse. It started out, I discovered it would not home unless homing was set to true, which I did. I wired up limit switches to X and Y. then I discovered I needed a Z limit and motor, so I rigged that up. The system would “Home”, but it was always going to the bottom right. From there, if I tried to run a job, it would hit the bottom limit switch first thing and kill the job with alarm error 1. I tried a few things and now It wont home. the z axis has to be right near the stop, and the XY will move a couple of bumps, then stop. I can manually position the laser, run the job, and it lases the patterns I send it. I tried watching the video on origin etc, but that assumes I have a machine that homes.

Can anyone help?

There are homing direction settings in GRBL as well, so it sounds like you need to set the homing direction invert mask ($23) different than what you have.

$23=0 is the default
$23=1 will invert the X homing direction, which sounds like what you need (and you’d have to put the limit switch on the other side too)

The mask is a sum of bits for the directions to invert
1 = x
2 = y
4 = z

So if you wanted to invert both x and y it would be 3 (1 +2). If you wanted to invert y & z it would be 6 (2+4).

Thanks for the reply. I’m unable to get it to home in any direction now. Still jogs, limit switches still work, i can get it to engrave, just will not move when I try to home now.

Update, it gets error 8 when attempting to home.

That seems to mean it’s busy:
“Error 8: Grbl ‘$’ command cannot be used unless Grbl is IDLE. Ensures smooth operation during a job.“

Yeah, I have the error list. I dont know why it started or how to fix it.

Is it already trying to home when you connect to LightBurn? (Do you have Home on Startup enabled in the device setup?)

It doesn’t do anything then. I says in the console “homing” but goes past it in a few seconds.

I was suggesting that if you have that enabled you should turn it off, because it might be that the device is trying to home already when you are entering your commands.

I will try that. Is there a way to set lightburn back to defaults? I tried uninstall but it seems to have remembered everything. Or, is there a g-code sender you can recommend I test my hardware with? Right now, jogging isn’t working right either.

To reset everything to defaults:

  • File => Open Prefs Folder
  • Quit LightBurn
  • Delete prefs files

For GCode senders, any serial terminal will work, and the console in LightBurn will do the job too, though it only sends after you press enter.

Thanks. I’m going to try defaults.

If you do not have a moving Z axis . Grbl is busy because it is waiting for the z to home. Rather than add a z switch disable it in the config.h and reflash your board

I have a Z axis with limits. It was working, now, if will only move a tiny bit when homing.

I have it back to where it’s homing. I for some reason, had to invert the limits. Strange. I may know why.

Anyway, it’s back to where now maybe I can understand the homing instructional video.

Thank you for your help, I’ll let you know how it goes.

I have the machine homing now. After homing, I can get my current position and it shows:

X=-195.01 Y=-4.99 Z=-5.00 U=0.00

I have the homing retract set at 5mm, and the machine set at 150x150mm
When I attempt to run a job, the laser hits the top limit.

0,0 is bottom left.

What am I doing wrong? What other information can I give you.

Grbl 1.1f settings below:

$0=10 (Step pulse time)
$1=25 (Step idle delay)
$2=0 (Step pulse invert)
$3=0 (Step direction invert)
$4=0 (Invert step enable pin)
$5=1 (Invert limit pins)
$6=0 (Invert probe pin)
$10=1 (Status report options)
$11=0.010 (Junction deviation)
$12=0.002 (Arc tolerance)
$13=0 (Report in inches)
$20=0 (Soft limits enable)
$21=1 (Hard limits enable)
$22=1 (Homing cycle enable)
$23=1 (Homing direction invert)
$24=25.000 (Homing locate feed rate)
$25=500.000 (Homing search seek rate)
$26=250 (Homing switch debounce delay)
$27=5.000 (Homing switch pull-off distance)
$30=1000 (Maximum spindle speed)
$31=0 (Minimum spindle speed)
$32=1 (Laser-mode enable)
$100=88.890 (X-axis travel resolution)
$101=88.890 (Y-axis travel resolution)
$102=250.000 (Z-axis travel resolution)
$110=500.000 (X-axis maximum rate)
$111=500.000 (Y-axis maximum rate)
$112=500.000 (Z-axis maximum rate)
$120=10.000 (X-axis acceleration)
$121=10.000 (Y-axis acceleration)
$122=10.000 (Z-axis acceleration)
$130=200.000 (X-axis maximum travel)
$131=200.000 (Y-axis maximum travel)
$132=200.000 (Z-axis maximum travel)

Your machine appears to be using negative workspace coordinates, which is normal for some reason on CNC setups, but not with laser setups. You can either use a workspace offset to shift the origin so the workspace is positive, or there’s a flag in GRBL (when compiling it) to make it not apply negative workspace.

This will explain the workspace offset:

And here is info on the negative coordinates change:

I’d be happy to change whatever GRBL make my machine works the simplest. It’s a new setup. I dont have to maintain any compatibility with legacy software.

I’m used to putting the work to the top left corner and it works. If there is a way I can make this happen. I cant seem to figure out what I’m doing wrong. Like I say, it’s a new install, Grbl on a arduino clone board with CNC outputs for limits, motors, etc. I’m happy to change anything to make it work the way My K40 does.

I’ll be happy to buy a new board. Anything.

If you read the “Common GRBL setups” doc page I linked above, it walks you through setting up a workspace offset. That would do it.